[lantiq]
[openwrt.git] / target / linux / lantiq / patches-3.0 / 460-mach-dgn3500.patch
diff --git a/target/linux/lantiq/patches-3.0/460-mach-dgn3500.patch b/target/linux/lantiq/patches-3.0/460-mach-dgn3500.patch
deleted file mode 100644 (file)
index dc90425..0000000
+++ /dev/null
@@ -1,92 +0,0 @@
---- a/arch/mips/lantiq/machtypes.h
-+++ b/arch/mips/lantiq/machtypes.h
-@@ -33,6 +33,9 @@ enum lantiq_mach_type {
-       LANTIQ_MACH_ARV752DPW,          /* Arcor easybox a802 */
-       LANTIQ_MACH_ARV752DPW22,        /* Arcor easybox a803 */
-       LANTIQ_MACH_ARV7518PW,          /* ASTORIA */
-+
-+      /* Netgear */
-+      LANTIQ_MACH_DGN3500B,           /* Netgear DGN3500 */
- };
- #endif
---- a/arch/mips/lantiq/xway/Kconfig
-+++ b/arch/mips/lantiq/xway/Kconfig
-@@ -10,6 +10,10 @@ config LANTIQ_MACH_ARV45XX
-       bool "ARV45XX"
-       default y
-+config LANTIQ_MACH_NETGEAR
-+      bool "Netgear"
-+      default y
-+
- endmenu
- endif
---- a/arch/mips/lantiq/xway/Makefile
-+++ b/arch/mips/lantiq/xway/Makefile
-@@ -6,3 +6,4 @@ obj-$(CONFIG_SOC_AMAZON_SE) += clk-ase.o
- obj-$(CONFIG_LANTIQ_MACH_EASY50712) += mach-easy50712.o
- obj-$(CONFIG_LANTIQ_MACH_EASY50601) += mach-easy50601.o
- obj-$(CONFIG_LANTIQ_MACH_ARV45XX) += mach-arv45xx.o
-+obj-$(CONFIG_LANTIQ_MACH_NETGEAR) += mach-netgear.o
---- /dev/null
-+++ b/arch/mips/lantiq/xway/mach-netgear.c
-@@ -0,0 +1,57 @@
-+/*
-+ *  This program is free software; you can redistribute it and/or modify it
-+ *  under the terms of the GNU General Public License version 2 as published
-+ *  by the Free Software Foundation.
-+ *
-+ *  Copyright (C) 2010 John Crispin <blogic@openwrt.org>
-+ */
-+
-+#include <linux/init.h>
-+#include <linux/platform_device.h>
-+#include <linux/mtd/mtd.h>
-+#include <linux/mtd/partitions.h>
-+#include <linux/mtd/physmap.h>
-+#include <linux/input.h>
-+#include <linux/phy.h>
-+#include <linux/spi/spi.h>
-+
-+#include <lantiq_soc.h>
-+#include <irq.h>
-+
-+#include "../machtypes.h"
-+#include "devices.h"
-+
-+static struct ltq_pci_data ltq_pci_data = {
-+      .clock  = PCI_CLOCK_INT,
-+      .gpio   = PCI_GNT1 | PCI_REQ1,
-+      .irq    = {
-+              [14] = INT_NUM_IM0_IRL0 + 22,
-+      },
-+};
-+
-+static struct ltq_eth_data ltq_eth_data = {
-+      .mii_mode = PHY_INTERFACE_MODE_MII,
-+};
-+
-+struct spi_board_info spi_info = {
-+      .bus_num        = 0,
-+      .chip_select    = 3,
-+      .max_speed_hz   = 25000000,
-+      .modalias       = "mx25l12805d",
-+};
-+
-+struct ltq_spi_platform_data ltq_spi_data = {
-+      .num_chipselect = 4,
-+};
-+
-+static void __init dgn3500_init(void)
-+{
-+      ltq_register_pci(&ltq_pci_data);
-+      ltq_register_etop(&ltq_eth_data);
-+      ltq_register_spi(&ltq_spi_data, &spi_info, 1);
-+}
-+
-+MIPS_MACHINE(LANTIQ_MACH_DGN3500B,
-+           "DGN3500B",
-+           "Netgear DGN3500B",
-+            dgn3500_init);