lantiq: add devicetree for TP-Link TDW8970
[openwrt.git] / target / linux / lantiq / Makefile
index a8e6170..25fea54 100644 (file)
@@ -8,14 +8,12 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=lantiq
 BOARDNAME:=Lantiq GPON/XWAY/SVIP
-FEATURES:=squashfs jffs2
-SUBTARGETS:=danube ar9 vr9 falcon svip_be
-LINUX_VERSION:=3.3.8
-
+FEATURES:=squashfs
 SUBTARGETS=xway ase falcon
-LINUX_VERSION:=3.7-rc8
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+LINUX_VERSION:=3.8.13
+
+CFLAGS=-Os -pipe -mips32r2 -fno-caller-saves -mno-branch-likely
 
 define Target/Description
        Build firmware images for Lantiq SoC