uboot-zynq: Update to U-Boot 2016.03 release
[openwrt.git] / target / linux / kirkwood / profiles / 110-nas.mk
index 1bd188c..bf97437 100644 (file)
@@ -8,8 +8,7 @@
 define Profile/DOCKSTAR
   NAME:=Seagate FreeAgent Dockstar
   PACKAGES:= \
-       kmod-rtc-marvell kmod-usb2 kmod-usb-storage \
-       uboot-envtools
+       kmod-rtc-marvell kmod-usb2 kmod-usb-storage
 endef
 
 define Profile/DOCKSTAR/Description
@@ -21,14 +20,30 @@ DOCKSTAR_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
 
 $(eval $(call Profile,DOCKSTAR))
 
-define Profile/GOFLEXNET
-  NAME:=Seagate GoFlexNet
+define Profile/GOFLEXHOME
+  NAME:=Seagate GoFlexHome
   PACKAGES:= \
        kmod-ata-core kmod-ata-marvell-sata \
        kmod-rtc-marvell kmod-usb2 kmod-usb-storage \
        uboot-envtools
 endef
 
+define Profile/GOFLEXHOME/Description
+ Package set compatible with Seagate GoFlexHome
+endef
+
+GOFLEXHOME_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+GOFLEXHOME_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,GOFLEXHOME))
+
+define Profile/GOFLEXNET
+  NAME:=Seagate GoFlexNet
+  PACKAGES:= \
+       kmod-ata-core kmod-ata-marvell-sata \
+       kmod-usb2 kmod-usb-storage
+endef
+
 define Profile/GOFLEXNET/Description
  Package set compatible with Seagate GoFlexNet
 endef
@@ -42,8 +57,7 @@ define Profile/IB62X0
   NAME:=RaidSonic ICY BOX IB-NAS62x0
   PACKAGES:= \
        kmod-ata-core kmod-ata-marvell-sata \
-       kmod-rtc-marvell kmod-usb2 kmod-usb-storage \
-       uboot-envtools
+       kmod-rtc-marvell kmod-usb2 kmod-usb-storage
 endef
 
 define Profile/IB62X0/Description
@@ -70,28 +84,11 @@ ICONNECT_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
 
 $(eval $(call Profile,ICONNECT))
 
-define Profile/POGOE02
-  NAME:=Cloud Engines Pogoplug E02
-  PACKAGES:= \
-       kmod-usb2 kmod-usb-storage uboot-envtools
-endef
-
-define Profile/POGOE02/Description
- Package set compatible with Cloud Engines Pogoplug E02 board.
-endef
-
-POGOE02_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
-POGOE02_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
-
-$(eval $(call Profile,POGOE02))
-
-
 define Profile/IOMEGA_IX2_200
   NAME:=Iomega StorCenter ix2-200
   PACKAGES:= \
        kmod-ata-core kmod-ata-marvell-sata \
-       kmod-usb2 kmod-usb-storage \
-       uboot-envtools
+       kmod-usb2 kmod-usb-storage
 endef
 
 define Profile/IOMEGA_IX2_200/Description
@@ -103,3 +100,33 @@ IOMEGA_IX2_200_UBI_OPTS:="-m 512 -p 16384 -s 256"
 
 $(eval $(call Profile,IOMEGA_IX2_200))
 
+define Profile/NSA310S
+  NAME:=ZyXEL NSA310S
+  PACKAGES:= \
+       kmod-ata-core kmod-ata-marvell-sata \
+       kmod-rtc-marvell kmod-usb2 kmod-usb-storage
+endef
+
+define Profile/NSA310S/Description
+ Package set compatible with ZyXEL NSA310S board.
+endef
+
+NSA310S_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+NSA310S_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,NSA310S))
+
+define Profile/POGOE02
+  NAME:=Cloud Engines Pogoplug E02
+  PACKAGES:= \
+       kmod-usb2 kmod-usb-storage
+endef
+
+define Profile/POGOE02/Description
+ Package set compatible with Cloud Engines Pogoplug E02 board.
+endef
+
+POGOE02_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+POGOE02_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,POGOE02))