refresh ixp4xx patches to match upstream style
[openwrt.git] / target / linux / ixp4xx / patches-2.6.25 / 130-wrt300nv2_support.patch
index 5665f65..b797cb4 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/arch/arm/mach-ixp4xx/Kconfig
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/Kconfig
-@@ -73,6 +73,14 @@ config MACH_COMPEX
+--- a/arch/arm/mach-ixp4xx/Kconfig
++++ b/arch/arm/mach-ixp4xx/Kconfig
+@@ -73,6 +73,14 @@
          WP18 or NP18A boards. For more information on this
          platform, see http://openwrt.org
  
@@ -17,11 +15,9 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Kconfig
  config ARCH_IXDP425
        bool "IXDP425"
        help
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
-===================================================================
---- linux-2.6.25.4.orig/arch/arm/mach-ixp4xx/Makefile
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
-@@ -18,6 +18,7 @@ obj-pci-$(CONFIG_MACH_WG302V2)               += wg302
+--- a/arch/arm/mach-ixp4xx/Makefile
++++ b/arch/arm/mach-ixp4xx/Makefile
+@@ -18,6 +18,7 @@
  obj-pci-$(CONFIG_MACH_FSG)            += fsg-pci.o
  obj-pci-$(CONFIG_MACH_PRONGHORNMETRO) += pronghornmetro-pci.o
  obj-pci-$(CONFIG_MACH_COMPEX)         += ixdp425-pci.o
@@ -29,7 +25,7 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
  
  obj-y += common.o
  
-@@ -34,6 +35,7 @@ obj-$(CONFIG_MACH_WG302V2)   += wg302v2-se
+@@ -34,6 +35,7 @@
  obj-$(CONFIG_MACH_FSG)                += fsg-setup.o
  obj-$(CONFIG_MACH_PRONGHORNMETRO)     += pronghornmetro-setup.o
  obj-$(CONFIG_MACH_COMPEX)     += compex-setup.o
@@ -37,10 +33,8 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
  
  obj-$(CONFIG_PCI)             += $(obj-pci-$(CONFIG_PCI)) common-pci.o
  obj-$(CONFIG_IXP4XX_QMGR)     += ixp4xx_qmgr.o
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/wrt300nv2-pci.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/wrt300nv2-pci.c
++++ b/arch/arm/mach-ixp4xx/wrt300nv2-pci.c
 @@ -0,0 +1,65 @@
 +/*
 + * arch/arch/mach-ixp4xx/wrt300nv2-pci.c
@@ -107,10 +101,8 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/wrt300nv2-pci.c
 +}
 +
 +subsys_initcall(wrt300nv2_pci_init);
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/wrt300nv2-setup.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/wrt300nv2-setup.c
++++ b/arch/arm/mach-ixp4xx/wrt300nv2-setup.c
 @@ -0,0 +1,108 @@
 +/*
 + * arch/arm/mach-ixp4xx/wrt300nv2-setup.c
@@ -220,11 +212,9 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/wrt300nv2-setup.c
 +      .init_machine   = wrt300nv2_init,
 +MACHINE_END
 +#endif
-Index: linux-2.6.25.4/include/asm-arm/arch-ixp4xx/uncompress.h
-===================================================================
---- linux-2.6.25.4.orig/include/asm-arm/arch-ixp4xx/uncompress.h
-+++ linux-2.6.25.4/include/asm-arm/arch-ixp4xx/uncompress.h
-@@ -42,7 +42,7 @@ static __inline__ void __arch_decomp_set
+--- a/include/asm-arm/arch-ixp4xx/uncompress.h
++++ b/include/asm-arm/arch-ixp4xx/uncompress.h
+@@ -42,7 +42,7 @@
         */
        if (machine_is_adi_coyote() || machine_is_gtwx5715() ||
                         machine_is_gateway7001() || machine_is_wg302v2() ||