ixp4xx/patches-2.6.24: Refreshed fsg patch and other affected patches
[openwrt.git] / target / linux / ixp4xx / patches-2.6.24 / 110-pronghorn_metro_support.patch
index 80115b8..fb895e0 100644 (file)
@@ -1,7 +1,7 @@
-Index: linux-2.6.23.12/arch/arm/mach-ixp4xx/Kconfig
+Index: linux-2.6.24/arch/arm/mach-ixp4xx/Kconfig
 ===================================================================
---- linux-2.6.23.12.orig/arch/arm/mach-ixp4xx/Kconfig  2008-01-05 13:30:14.000000000 +1030
-+++ linux-2.6.23.12/arch/arm/mach-ixp4xx/Kconfig       2008-01-05 13:37:05.000000000 +1030
+--- linux-2.6.24.orig/arch/arm/mach-ixp4xx/Kconfig     2008-03-12 21:21:23.000000000 +1030
++++ linux-2.6.24/arch/arm/mach-ixp4xx/Kconfig  2008-03-12 21:21:26.000000000 +1030
 @@ -57,6 +57,14 @@
          WG302 v2 or WAG302 v2 Access Points. For more information
          on this platform, see http://openwrt.org
@@ -17,10 +17,10 @@ Index: linux-2.6.23.12/arch/arm/mach-ixp4xx/Kconfig
  config ARCH_IXDP425
        bool "IXDP425"
        help
-Index: linux-2.6.23.12/arch/arm/mach-ixp4xx/Makefile
+Index: linux-2.6.24/arch/arm/mach-ixp4xx/Makefile
 ===================================================================
---- linux-2.6.23.12.orig/arch/arm/mach-ixp4xx/Makefile 2008-01-05 13:32:45.000000000 +1030
-+++ linux-2.6.23.12/arch/arm/mach-ixp4xx/Makefile      2008-01-05 13:37:37.000000000 +1030
+--- linux-2.6.24.orig/arch/arm/mach-ixp4xx/Makefile    2008-03-12 21:21:23.000000000 +1030
++++ linux-2.6.24/arch/arm/mach-ixp4xx/Makefile 2008-03-12 21:21:26.000000000 +1030
 @@ -16,6 +16,7 @@
  obj-pci-$(CONFIG_MACH_GATEWAY7001)    += gateway7001-pci.o
  obj-pci-$(CONFIG_MACH_WG302V2)                += wg302v2-pci.o
@@ -32,14 +32,14 @@ Index: linux-2.6.23.12/arch/arm/mach-ixp4xx/Makefile
 @@ -30,5 +31,6 @@
  obj-$(CONFIG_MACH_GATEWAY7001)        += gateway7001-setup.o
  obj-$(CONFIG_MACH_WG302V2)    += wg302v2-setup.o
- obj-$(CONFIG_MACH_FSG)                += fsg-setup.o fsg-power.o
+ obj-$(CONFIG_MACH_FSG)                += fsg-setup.o
 +obj-$(CONFIG_MACH_PRONGHORNMETRO)     += pronghornmetro-setup.o
  
  obj-$(CONFIG_PCI)             += $(obj-pci-$(CONFIG_PCI)) common-pci.o
-Index: linux-2.6.23.12/arch/arm/mach-ixp4xx/pronghornmetro-pci.c
+Index: linux-2.6.24/arch/arm/mach-ixp4xx/pronghornmetro-pci.c
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23.12/arch/arm/mach-ixp4xx/pronghornmetro-pci.c  2008-01-05 13:37:05.000000000 +1030
++++ linux-2.6.24/arch/arm/mach-ixp4xx/pronghornmetro-pci.c     2008-03-12 21:21:26.000000000 +1030
 @@ -0,0 +1,74 @@
 +/*
 + * arch/arch/mach-ixp4xx/pronghornmetro-pci.c
@@ -115,10 +115,10 @@ Index: linux-2.6.23.12/arch/arm/mach-ixp4xx/pronghornmetro-pci.c
 +}
 +
 +subsys_initcall(pronghornmetro_pci_init);
-Index: linux-2.6.23.12/arch/arm/mach-ixp4xx/pronghornmetro-setup.c
+Index: linux-2.6.24/arch/arm/mach-ixp4xx/pronghornmetro-setup.c
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23.12/arch/arm/mach-ixp4xx/pronghornmetro-setup.c        2008-01-05 13:37:05.000000000 +1030
++++ linux-2.6.24/arch/arm/mach-ixp4xx/pronghornmetro-setup.c   2008-03-12 21:21:26.000000000 +1030
 @@ -0,0 +1,147 @@
 +/*
 + * arch/arm/mach-ixp4xx/pronghornmetro-setup.c
@@ -267,10 +267,10 @@ Index: linux-2.6.23.12/arch/arm/mach-ixp4xx/pronghornmetro-setup.c
 +      .init_machine   = pronghornmetro_init,
 +MACHINE_END
 +#endif
-Index: linux-2.6.23.12/Documentation/arm/IXP4xx
+Index: linux-2.6.24/Documentation/arm/IXP4xx
 ===================================================================
---- linux-2.6.23.12.orig/Documentation/arm/IXP4xx      2008-01-05 13:30:14.000000000 +1030
-+++ linux-2.6.23.12/Documentation/arm/IXP4xx   2008-01-05 13:37:05.000000000 +1030
+--- linux-2.6.24.orig/Documentation/arm/IXP4xx 2008-03-12 21:20:48.000000000 +1030
++++ linux-2.6.24/Documentation/arm/IXP4xx      2008-03-12 21:21:26.000000000 +1030
 @@ -111,6 +111,9 @@
     the platform has two mini-PCI slots used for 802.11[bga] cards.
     Finally, there is an IDE port hanging off the expansion bus.
@@ -281,10 +281,10 @@ Index: linux-2.6.23.12/Documentation/arm/IXP4xx
  Gateworks Avila Network Platform
  http://www.gateworks.com/avila_sbc.htm
  
-Index: linux-2.6.23.12/include/asm-arm/arch-ixp4xx/uncompress.h
+Index: linux-2.6.24/include/asm-arm/arch-ixp4xx/uncompress.h
 ===================================================================
---- linux-2.6.23.12.orig/include/asm-arm/arch-ixp4xx/uncompress.h      2008-01-05 13:30:14.000000000 +1030
-+++ linux-2.6.23.12/include/asm-arm/arch-ixp4xx/uncompress.h   2008-01-05 13:37:05.000000000 +1030
+--- linux-2.6.24.orig/include/asm-arm/arch-ixp4xx/uncompress.h 2008-03-12 21:20:48.000000000 +1030
++++ linux-2.6.24/include/asm-arm/arch-ixp4xx/uncompress.h      2008-03-12 21:21:26.000000000 +1030
 @@ -41,7 +41,8 @@
         * Some boards are using UART2 as console
         */