kernel: update 3.14 to 3.14.18
[openwrt.git] / target / linux / ipq806x / patches / 0003-ARM-msm-kill-off-hotplug.c.patch
index b6e9bba..79aa96f 100644 (file)
@@ -16,11 +16,9 @@ Signed-off-by: Kumar Gala <galak@codeaurora.org>
  4 files changed, 7 insertions(+), 53 deletions(-)
  delete mode 100644 arch/arm/mach-msm/hotplug.c
 
-diff --git a/arch/arm/mach-msm/Makefile b/arch/arm/mach-msm/Makefile
-index 721f27f..8327f60 100644
 --- a/arch/arm/mach-msm/Makefile
 +++ b/arch/arm/mach-msm/Makefile
-@@ -18,7 +18,6 @@ obj-$(CONFIG_MSM_SCM) += scm.o scm-boot.o
+@@ -18,7 +18,6 @@ obj-$(CONFIG_MSM_SCM) += scm.o scm-boot.
  
  CFLAGS_scm.o :=$(call as-instr,.arch_extension sec,-DREQUIRES_SEC=1)
  
@@ -28,11 +26,9 @@ index 721f27f..8327f60 100644
  obj-$(CONFIG_SMP) += platsmp.o
  
  obj-$(CONFIG_MACH_TROUT) += board-trout.o board-trout-gpio.o board-trout-mmc.o devices-msm7x00.o
-diff --git a/arch/arm/mach-msm/common.h b/arch/arm/mach-msm/common.h
-index 33c7725..0a4899b 100644
 --- a/arch/arm/mach-msm/common.h
 +++ b/arch/arm/mach-msm/common.h
-@@ -24,7 +24,6 @@ extern void __iomem *__msm_ioremap_caller(phys_addr_t phys_addr, size_t size,
+@@ -24,7 +24,6 @@ extern void __iomem *__msm_ioremap_calle
                                          unsigned int mtype, void *caller);
  
  extern struct smp_operations msm_smp_ops;
@@ -40,9 +36,6 @@ index 33c7725..0a4899b 100644
  
  struct msm_mmc_platform_data;
  
-diff --git a/arch/arm/mach-msm/hotplug.c b/arch/arm/mach-msm/hotplug.c
-deleted file mode 100644
-index cea80fc..0000000
 --- a/arch/arm/mach-msm/hotplug.c
 +++ /dev/null
 @@ -1,51 +0,0 @@
@@ -97,8 +90,6 @@ index cea80fc..0000000
 -       */
 -      cpu_leave_lowpower();
 -}
-diff --git a/arch/arm/mach-msm/platsmp.c b/arch/arm/mach-msm/platsmp.c
-index 3721b31..251a91e 100644
 --- a/arch/arm/mach-msm/platsmp.c
 +++ b/arch/arm/mach-msm/platsmp.c
 @@ -29,6 +29,13 @@ extern void secondary_startup(void);
@@ -115,6 +106,3 @@ index 3721b31..251a91e 100644
  static inline int get_core_count(void)
  {
        /* 1 + the PART[1:0] field of MIDR */
--- 
-1.7.10.4
-