generic: ar8216: add support for the AR8327 chip
[openwrt.git] / target / linux / imx21 / Makefile
index 96a2784..0ca5c8a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,10 +9,10 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=imx21
 BOARDNAME:=Freescale i.MX21
-FEATURES:=jffs2
-CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
+FEATURES:=jffs2 broken
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
 
-LINUX_VERSION:=2.6.34.1
+LINUX_VERSION:=2.6.37.6
 
 DEVICE_TYPE=phone