rename the mx2 target to imx21
[openwrt.git] / target / linux / imx21 / Makefile
diff --git a/target/linux/imx21/Makefile b/target/linux/imx21/Makefile
new file mode 100644 (file)
index 0000000..96a2784
--- /dev/null
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=imx21
+BOARDNAME:=Freescale i.MX21
+FEATURES:=jffs2
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
+
+LINUX_VERSION:=2.6.34.1
+
+DEVICE_TYPE=phone
+
+define Target/Description
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))