remove linux 2.4 specific build system code
[15.05/openwrt.git] / target / linux / generic-2.6 / patches-2.6.34 / 970-ocf_kbuild_integration.patch
index 3a285de..76413e9 100644 (file)
@@ -1,25 +1,20 @@
 --- a/crypto/Kconfig
 +++ b/crypto/Kconfig
-@@ -833,6 +833,8 @@ config CRYPTO_ANSI_CPRNG
-         ANSI X9.31 A.2.4. Note that this option must be enabled if
-         CRYPTO_FIPS is selected
-+source "crypto/ocf/Kconfig"
-+
+@@ -836,3 +836,6 @@ config CRYPTO_ANSI_CPRNG
  source "drivers/crypto/Kconfig"
  
  endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
 --- a/crypto/Makefile
 +++ b/crypto/Makefile
-@@ -87,6 +87,11 @@ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
+@@ -86,6 +86,8 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
+ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
  obj-$(CONFIG_CRYPTO_GHASH) += ghash-generic.o
  
- #
-+# OCF
-+#
 +obj-$(CONFIG_OCF_OCF) += ocf/
 +
-+#
+ #
  # generic algorithms and the async_tx api
  #
- obj-$(CONFIG_XOR_BLOCKS) += xor.o