remove linux 2.4 specific build system code
[15.05/openwrt.git] / target / linux / generic-2.6 / patches-2.6.31 / 051-lzo_compressed_kernel_for_arm.patch
index f155c0a..49512bb 100644 (file)
@@ -1,5 +1,3 @@
-diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
-index 1c4119c..350921d 100644
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
 @@ -18,6 +18,8 @@ config ARM
@@ -11,8 +9,6 @@ index 1c4119c..350921d 100644
        help
          The ARM series is a line of low-power-consumption RISC chip designs
          licensed by ARM Ltd and targeted at embedded applications and
-diff --git a/arch/arm/boot/compressed/Makefile b/arch/arm/boot/compressed/Makefile
-index ce39dc5..5b4629b 100644
 --- a/arch/arm/boot/compressed/Makefile
 +++ b/arch/arm/boot/compressed/Makefile
 @@ -63,8 +63,12 @@ endif
@@ -69,8 +65,6 @@ index ce39dc5..5b4629b 100644
  
  CFLAGS_font.o := -Dstatic=
  
-diff --git a/arch/arm/boot/compressed/misc.c b/arch/arm/boot/compressed/misc.c
-index 17153b5..7e0fe4d 100644
 --- a/arch/arm/boot/compressed/misc.c
 +++ b/arch/arm/boot/compressed/misc.c
 @@ -18,10 +18,15 @@
@@ -89,7 +83,7 @@ index 17153b5..7e0fe4d 100644
  
  #ifdef STANDALONE_DEBUG
  #define putstr printf
-@@ -188,34 +193,8 @@ static inline __ptr_t memcpy(__ptr_t __dest, __const __ptr_t __src,
+@@ -188,34 +193,8 @@ static inline __ptr_t memcpy(__ptr_t __d
  /*
   * gzip delarations
   */
@@ -124,7 +118,7 @@ index 17153b5..7e0fe4d 100644
  /* Diagnostic functions */
  #ifdef DEBUG
  #  define Assert(cond,msg) {if(!(cond)) error(msg);}
-@@ -233,24 +212,20 @@ static unsigned outcnt;          /* bytes in output buffer */
+@@ -233,24 +212,20 @@ static unsigned outcnt;          /* bytes in out
  #  define Tracecv(c,x)
  #endif
  
@@ -260,9 +254,6 @@ index 17153b5..7e0fe4d 100644
  }
  #endif
 -      
-diff --git a/arch/arm/boot/compressed/piggy.S b/arch/arm/boot/compressed/piggy.S
-deleted file mode 100644
-index 54c9518..0000000
 --- a/arch/arm/boot/compressed/piggy.S
 +++ /dev/null
 @@ -1,6 +0,0 @@
@@ -272,9 +263,6 @@ index 54c9518..0000000
 -      .incbin "arch/arm/boot/compressed/piggy.gz"
 -      .globl  input_data_end
 -input_data_end:
-diff --git a/arch/arm/boot/compressed/piggy.gzip.S b/arch/arm/boot/compressed/piggy.gzip.S
-new file mode 100644
-index 0000000..a68adf9
 --- /dev/null
 +++ b/arch/arm/boot/compressed/piggy.gzip.S
 @@ -0,0 +1,6 @@
@@ -284,9 +272,6 @@ index 0000000..a68adf9
 +      .incbin "arch/arm/boot/compressed/piggy.gzip"
 +      .globl  input_data_end
 +input_data_end:
-diff --git a/arch/arm/boot/compressed/piggy.lzo.S b/arch/arm/boot/compressed/piggy.lzo.S
-new file mode 100644
-index 0000000..a425ad9
 --- /dev/null
 +++ b/arch/arm/boot/compressed/piggy.lzo.S
 @@ -0,0 +1,6 @@