[kernel] refresh generic 2.6.26 patches
[openwrt.git] / target / linux / generic-2.6 / patches-2.6.26 / 100-netfilter_layer7_2.17.patch
index 917adc5..451dfe9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/netfilter/Kconfig
 +++ b/net/netfilter/Kconfig
-@@ -735,6 +735,27 @@
+@@ -749,6 +749,27 @@
  
          To compile it as a module, choose M here.  If unsure, say N.
  
@@ -30,7 +30,7 @@
        depends on NETFILTER_XTABLES
 --- a/net/netfilter/Makefile
 +++ b/net/netfilter/Makefile
-@@ -77,6 +77,7 @@
+@@ -78,6 +78,7 @@
  obj-$(CONFIG_NETFILTER_XT_MATCH_REALM) += xt_realm.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o
 +}
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -210,6 +210,14 @@
+@@ -207,6 +207,14 @@
         * too. */
        nf_ct_remove_expectations(ct);
  
                BUG_ON(hlist_unhashed(&ct->tuplehash[IP_CT_DIR_ORIGINAL].hnode));
 --- a/net/netfilter/nf_conntrack_standalone.c
 +++ b/net/netfilter/nf_conntrack_standalone.c
-@@ -181,7 +181,12 @@
+@@ -174,7 +174,12 @@
                return -ENOSPC;
  #endif