remove linux 2.4 specific build system code
[openwrt.git] / target / linux / generic-2.6 / patches-2.6.25 / 420-gpiodev.patch
index 4c252f5..de8b57a 100644 (file)
@@ -1,10 +1,8 @@
-Index: linux-2.6.25/drivers/gpio/Kconfig
-===================================================================
---- linux-2.6.25.orig/drivers/gpio/Kconfig     2008-04-27 23:35:57.000000000 +0100
-+++ linux-2.6.25/drivers/gpio/Kconfig  2008-04-27 23:42:52.000000000 +0100
-@@ -2,6 +2,13 @@
- # GPIO infrastructure and expanders
- #
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -955,6 +955,13 @@ config CS5535_GPIO
+         If compiled as a module, it will be called cs5535_gpio.
  
 +config GPIO_DEVICE
 +      tristate "GPIO device support"
@@ -13,15 +11,16 @@ Index: linux-2.6.25/drivers/gpio/Kconfig
 +        Say Y to enable Linux GPIO device support.  This allows control of
 +        GPIO pins using a character device
 +
- config HAVE_GPIO_LIB
-       bool
-       help
-Index: linux-2.6.25/drivers/gpio/Makefile
-===================================================================
---- linux-2.6.25.orig/drivers/gpio/Makefile    2008-04-27 23:42:59.000000000 +0100
-+++ linux-2.6.25/drivers/gpio/Makefile 2008-04-27 23:43:41.000000000 +0100
-@@ -7,3 +7,4 @@ obj-$(CONFIG_HAVE_GPIO_LIB)    += gpiolib.o
- obj-$(CONFIG_GPIO_MCP23S08)   += mcp23s08.o
- obj-$(CONFIG_GPIO_PCA953X)    += pca953x.o
- obj-$(CONFIG_GPIO_PCF857X)    += pcf857x.o
+ config GPIO_VR41XX
+       tristate "NEC VR4100 series General-purpose I/O Unit support"
+       depends on CPU_VR41XX
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -94,6 +94,7 @@ obj-$(CONFIG_SCx200_GPIO)    += scx200_gpio
+ obj-$(CONFIG_PC8736x_GPIO)    += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO)                += nsc_gpio.o
+ obj-$(CONFIG_CS5535_GPIO)     += cs5535_gpio.o
 +obj-$(CONFIG_GPIO_DEVICE)     += gpio_dev.o
+ obj-$(CONFIG_GPIO_VR41XX)     += vr41xx_giu.o
+ obj-$(CONFIG_GPIO_TB0219)     += tb0219.o
+ obj-$(CONFIG_TELCLOCK)                += tlclk.o