refresh generic 2.6.25 patches to match upstream style
[openwrt.git] / target / linux / generic-2.6 / patches-2.6.25 / 200-sched_esfq.patch
index ac39a8c..1dfd95e 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.25.4/include/linux/pkt_sched.h
-===================================================================
---- linux-2.6.25.4.orig/include/linux/pkt_sched.h
-+++ linux-2.6.25.4/include/linux/pkt_sched.h
-@@ -162,8 +162,37 @@ struct tc_sfq_xstats
+--- a/include/linux/pkt_sched.h
++++ b/include/linux/pkt_sched.h
+@@ -162,8 +162,37 @@
   *
   *    The only reason for this is efficiency, it is possible
   *    to change these parameters in compile time.
@@ -40,11 +38,9 @@ Index: linux-2.6.25.4/include/linux/pkt_sched.h
  /* RED section */
  
  enum
-Index: linux-2.6.25.4/net/sched/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/net/sched/Kconfig
-+++ linux-2.6.25.4/net/sched/Kconfig
-@@ -139,6 +139,37 @@ config NET_SCH_SFQ
+--- a/net/sched/Kconfig
++++ b/net/sched/Kconfig
+@@ -139,6 +139,37 @@
          To compile this code as a module, choose M here: the
          module will be called sch_sfq.
  
@@ -82,11 +78,9 @@ Index: linux-2.6.25.4/net/sched/Kconfig
  config NET_SCH_TEQL
        tristate "True Link Equalizer (TEQL)"
        ---help---
-Index: linux-2.6.25.4/net/sched/Makefile
-===================================================================
---- linux-2.6.25.4.orig/net/sched/Makefile
-+++ linux-2.6.25.4/net/sched/Makefile
-@@ -23,6 +23,7 @@ obj-$(CONFIG_NET_SCH_GRED)   += sch_gred.o
+--- a/net/sched/Makefile
++++ b/net/sched/Makefile
+@@ -23,6 +23,7 @@
  obj-$(CONFIG_NET_SCH_INGRESS) += sch_ingress.o 
  obj-$(CONFIG_NET_SCH_DSMARK)  += sch_dsmark.o
  obj-$(CONFIG_NET_SCH_SFQ)     += sch_sfq.o
@@ -94,10 +88,8 @@ Index: linux-2.6.25.4/net/sched/Makefile
  obj-$(CONFIG_NET_SCH_TBF)     += sch_tbf.o
  obj-$(CONFIG_NET_SCH_TEQL)    += sch_teql.o
  obj-$(CONFIG_NET_SCH_PRIO)    += sch_prio.o
-Index: linux-2.6.25.4/net/sched/sch_esfq.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.25.4/net/sched/sch_esfq.c
++++ b/net/sched/sch_esfq.c
 @@ -0,0 +1,702 @@
 +/*
 + * net/sched/sch_esfq.c       Extended Stochastic Fairness Queueing discipline.