[kernel] refresh generic-2.4 patches
[openwrt.git] / target / linux / generic-2.4 / patches / 209-build_fixes.patch
index dbb5a88..30af60f 100644 (file)
@@ -1,8 +1,8 @@
 Index: linux-2.4.35.4/Makefile
 ===================================================================
---- linux-2.4.35.4.orig/Makefile       2007-12-15 05:19:51.427351715 +0100
-+++ linux-2.4.35.4/Makefile    2007-12-15 05:20:00.315858242 +0100
-@@ -362,7 +362,7 @@
+--- linux-2.4.35.4.orig/Makefile
++++ linux-2.4.35.4/Makefile
+@@ -362,7 +362,7 @@ include/linux/compile.h: $(CONFIGURATION
        @rm -f .ver1
  
  include/linux/version.h: ./Makefile
@@ -11,7 +11,7 @@ Index: linux-2.4.35.4/Makefile
          (echo KERNELRELEASE \"$(KERNELRELEASE)\" exceeds $(uts_len) characters >&2; false)
        @echo \#define UTS_RELEASE \"$(KERNELRELEASE)\" > .ver
        @echo \#define LINUX_VERSION_CODE `expr $(VERSION) \\* 65536 + $(PATCHLEVEL) \\* 256 + $(SUBLEVEL)` >> .ver
-@@ -500,7 +500,7 @@
+@@ -500,7 +500,7 @@ dep-files: scripts/mkdep archdep include
  ifdef CONFIG_MODVERSIONS
        $(MAKE) update-modverfile
  endif
@@ -22,9 +22,9 @@ Index: linux-2.4.35.4/Makefile
  ifdef CONFIG_MODVERSIONS
 Index: linux-2.4.35.4/Rules.make
 ===================================================================
---- linux-2.4.35.4.orig/Rules.make     2007-12-15 05:19:39.078648003 +0100
-+++ linux-2.4.35.4/Rules.make  2007-12-15 05:20:00.315858242 +0100
-@@ -126,7 +126,7 @@
+--- linux-2.4.35.4.orig/Rules.make
++++ linux-2.4.35.4/Rules.make
+@@ -126,7 +126,7 @@ endif
  # This make dependencies quickly
  #
  fastdep: dummy
@@ -33,7 +33,7 @@ Index: linux-2.4.35.4/Rules.make
  ifdef ALL_SUB_DIRS
        $(MAKE) $(patsubst %,_sfdep_%,$(ALL_SUB_DIRS)) _FASTDEP_ALL_SUB_DIRS="$(ALL_SUB_DIRS)"
  endif
-@@ -176,7 +176,14 @@
+@@ -176,7 +176,14 @@ modules: $(ALL_MOBJS) dummy \
  _modinst__: dummy
  ifneq "$(strip $(ALL_MOBJS))" ""
        mkdir -p $(MODLIB)/kernel/$(MOD_DESTDIR)