remove the old broadcom wl driver for linux 2.4
[openwrt.git] / target / linux / generic-2.4 / patches / 050-build_flags.patch
index 7c32c68..dd4b62c 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.4.35.4/arch/mips/Makefile
-===================================================================
---- linux-2.4.35.4.orig/arch/mips/Makefile
-+++ linux-2.4.35.4/arch/mips/Makefile
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
 @@ -44,10 +44,10 @@ MAKEBOOT = $(MAKE) -C arch/$(ARCH)/boot
  GCCFLAGS      := -I $(TOPDIR)/include/asm/gcc
  GCCFLAGS      += -G 0 -mno-abicalls -fno-pic -pipe
@@ -49,10 +47,8 @@ Index: linux-2.4.35.4/arch/mips/Makefile
  CFLAGS                += $(GCCFLAGS)
  
  LD            += -m $(ld-emul)
-Index: linux-2.4.35.4/Makefile
-===================================================================
---- linux-2.4.35.4.orig/Makefile
-+++ linux-2.4.35.4/Makefile
+--- a/Makefile
++++ b/Makefile
 @@ -17,7 +17,7 @@ HPATH        = $(TOPDIR)/include
  FINDHPATH     = $(HPATH)/asm $(HPATH)/linux $(HPATH)/scsi $(HPATH)/net $(HPATH)/math-emu
  
@@ -74,9 +70,9 @@ Index: linux-2.4.35.4/Makefile
          -fno-strict-aliasing -fno-common
  CFLAGS += -fno-builtin-strpbrk -fno-builtin-sprintf
  ifndef CONFIG_FRAME_POINTER
-@@ -105,6 +104,8 @@ if_gcc4 = $(shell if echo __GNUC__ | $(C
- # disable pointer signedness warnings in gcc 4.0
- CFLAGS += $(call check_gcc,-Wno-pointer-sign,)
+@@ -108,6 +107,8 @@ CFLAGS += $(call check_gcc,-Wno-pointer-
+ # disable stupid and dangerous "optimization" in gcc 3.2+
+ CFLAGS += $(call check_gcc,-fno-delete-null-pointer-checks,)
  
 +CFLAGS += $(call check_gcc, -funit-at-a-time,)
 +