generic: early (incomplete!) 4.0 support
[openwrt.git] / target / linux / generic / patches-4.0 / 722-phy_mvswitch.patch
diff --git a/target/linux/generic/patches-4.0/722-phy_mvswitch.patch b/target/linux/generic/patches-4.0/722-phy_mvswitch.patch
new file mode 100644 (file)
index 0000000..27faa7c
--- /dev/null
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -139,6 +139,10 @@ config ADM6996_PHY
+         Currently supports the ADM6996FC and ADM6996M switches.
+         Support for FC is very limited.
++config MVSWITCH_PHY
++      tristate "Driver for Marvell 88E6060 switches"
++      select ETHERNET_PACKET_MANGLE
++
+ config FIXED_PHY
+       tristate "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+       depends on PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -19,6 +19,7 @@ obj-$(CONFIG_BCM7XXX_PHY)    += bcm7xxx.o
+ obj-$(CONFIG_BCM87XX_PHY)     += bcm87xx.o
+ obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
+ obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
++obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
+ obj-$(CONFIG_REALTEK_PHY)     += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY)               += fixed_phy.o