kernel: remove linux 3.8 support
[openwrt.git] / target / linux / generic / patches-3.8 / 901-debloat_sock_diag.patch
diff --git a/target/linux/generic/patches-3.8/901-debloat_sock_diag.patch b/target/linux/generic/patches-3.8/901-debloat_sock_diag.patch
deleted file mode 100644 (file)
index 4065f8a..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
---- a/net/Kconfig
-+++ b/net/Kconfig
-@@ -87,6 +87,9 @@ source "net/netlabel/Kconfig"
- endif # if INET
-+config SOCK_DIAG
-+      bool
-+
- config NETWORK_SECMARK
-       bool "Security Marking"
-       help
---- a/net/core/Makefile
-+++ b/net/core/Makefile
-@@ -8,9 +8,9 @@ obj-y := sock.o request_sock.o skbuff.o
- obj-$(CONFIG_SYSCTL) += sysctl_net_core.o
- obj-y              += dev.o ethtool.o dev_addr_lists.o dst.o netevent.o \
--                      neighbour.o rtnetlink.o utils.o link_watch.o filter.o \
--                      sock_diag.o
-+                      neighbour.o rtnetlink.o utils.o link_watch.o filter.o
-+obj-$(CONFIG_SOCK_DIAG) += sock_diag.o
- obj-$(CONFIG_XFRM) += flow.o
- obj-y += net-sysfs.o
- obj-$(CONFIG_NET_PKTGEN) += pktgen.o
---- a/net/ipv4/Kconfig
-+++ b/net/ipv4/Kconfig
-@@ -404,6 +404,7 @@ config INET_LRO
- config INET_DIAG
-       tristate "INET: socket monitoring interface"
-+      select SOCK_DIAG
-       default y
-       ---help---
-         Support for INET (TCP, DCCP, etc) socket monitoring interface used by
---- a/net/unix/Kconfig
-+++ b/net/unix/Kconfig
-@@ -22,6 +22,7 @@ config UNIX
- config UNIX_DIAG
-       tristate "UNIX: socket monitoring interface"
-       depends on UNIX
-+      select SOCK_DIAG
-       default n
-       ---help---
-         Support for UNIX socket monitoring interface used by the ss tool.