linux: remove 3.7 support
[openwrt.git] / target / linux / generic / patches-3.7 / 830-ledtrig_morse.patch
diff --git a/target/linux/generic/patches-3.7/830-ledtrig_morse.patch b/target/linux/generic/patches-3.7/830-ledtrig_morse.patch
deleted file mode 100644 (file)
index aed116e..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/drivers/leds/Kconfig
-+++ b/drivers/leds/Kconfig
-@@ -559,4 +559,8 @@ config LEDS_TRIGGER_TRANSIENT
-         GPIO/PWM based hardware.
-         If unsure, say Y.
-+config LEDS_TRIGGER_MORSE
-+      tristate "LED Morse Trigger"
-+      depends on LEDS_TRIGGERS
-+
- endif # NEW_LEDS
---- a/drivers/leds/Makefile
-+++ b/drivers/leds/Makefile
-@@ -65,3 +65,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO)              += ledt
- obj-$(CONFIG_LEDS_TRIGGER_CPU)                += ledtrig-cpu.o
- obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
- obj-$(CONFIG_LEDS_TRIGGER_TRANSIENT)  += ledtrig-transient.o
-+obj-$(CONFIG_LEDS_TRIGGER_MORSE)      += ledtrig-morse.o
---- a/drivers/leds/ledtrig-morse.c
-+++ b/drivers/leds/ledtrig-morse.c
-@@ -26,7 +26,6 @@
- #include <linux/list.h>
- #include <linux/spinlock.h>
- #include <linux/device.h>
--#include <linux/sysdev.h>
- #include <linux/timer.h>
- #include <linux/ctype.h>
- #include <linux/leds.h>