kernel: don't hide the 'Warning: unable to open an initial console' message
[openwrt.git] / target / linux / generic / patches-3.3 / 729-phy-tantos.patch
index 203b3e6..99a4e71 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-3.3.7/drivers/net/phy/Kconfig
-===================================================================
---- linux-3.3.7.orig/drivers/net/phy/Kconfig   2012-05-27 18:09:00.129697447 +0200
-+++ linux-3.3.7/drivers/net/phy/Kconfig        2012-05-29 18:31:44.462611635 +0200
-@@ -207,3 +207,7 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -210,3 +210,8 @@ endif # PHYLIB
  config MICREL_KS8995MA
        tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
        depends on SPI
@@ -10,12 +8,11 @@ Index: linux-3.3.7/drivers/net/phy/Kconfig
 +config PSB6970_PHY
 +      tristate "Lantiq XWAY Tantos (PSB6970) Ethernet switch"
 +      select SWCONFIG
-Index: linux-3.3.7/drivers/net/phy/Makefile
-===================================================================
---- linux-3.3.7.orig/drivers/net/phy/Makefile  2012-05-27 18:09:00.129697447 +0200
-+++ linux-3.3.7/drivers/net/phy/Makefile       2012-05-29 18:30:59.286610634 +0200
-@@ -28,6 +28,7 @@
- obj-$(CONFIG_RTL8367_PHY)     += rtl8367.o
++      select ETHERNET_PACKET_MANGLE
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -29,6 +29,7 @@ obj-$(CONFIG_RTL8367_PHY)    += rtl8367.o
+ obj-$(CONFIG_RTL8367B_PHY)    += rtl8367b.o
  obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
  obj-$(CONFIG_MICREL_PHY)      += micrel.o
 +obj-$(CONFIG_PSB6970_PHY)     += psb6970.o