kernel: make zlib and lzo modules selectable
[openwrt.git] / target / linux / generic / patches-3.3 / 727-phy-rtl8367.patch
index 3af6101..a24f497 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -185,6 +185,10 @@ config RTL8366RB_PHY
+@@ -190,6 +190,10 @@ config RTL8366RB_PHY
        tristate "Driver for the Realtek RTL8366RB switch"
        select SWCONFIG
  
@@ -8,9 +8,9 @@
 +      tristate "Driver for the Realtek RTL8367R/M switches"
 +      select SWCONFIG
 +
- config RTL8366S_PHY_DEBUG_FS
-       bool "RTL8366 switch driver DEBUG_FS support"
-       depends on RTL8366S_PHY || RTL8366RB_PHY
+ endif # RTL8366_SMI
+ endif # PHYLIB
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
 @@ -25,6 +25,7 @@ obj-$(CONFIG_RTL8306_PHY)    += rtl8306.o