kernel: add support for linux 3.2.1
[openwrt.git] / target / linux / generic / patches-3.2 / 726-phy_rtl8366.patch
diff --git a/target/linux/generic/patches-3.2/726-phy_rtl8366.patch b/target/linux/generic/patches-3.2/726-phy_rtl8366.patch
new file mode 100644 (file)
index 0000000..080793d
--- /dev/null
@@ -0,0 +1,44 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -162,4 +162,29 @@ config MDIO_OCTEON
+         If in doubt, say Y.
++config RTL8366_SMI
++      tristate "Driver for the RTL8366 SMI interface"
++      depends on GENERIC_GPIO
++      ---help---
++        This module implements the SMI interface protocol which is used
++        by some RTL8366 ethernet switch devices via the generic GPIO API.
++
++if RTL8366_SMI
++
++config RTL8366S_PHY
++      tristate "Driver for the Realtek RTL8366S switch"
++      select SWCONFIG
++
++config RTL8366RB_PHY
++      tristate "Driver for the Realtek RTL8366RB switch"
++      select SWCONFIG
++
++config RTL8366S_PHY_DEBUG_FS
++      bool "RTL8366 switch driver DEBUG_FS support"
++      depends on RTL8366S_PHY || RTL8366RB_PHY
++      depends on DEBUG_FS
++      default n
++
++endif # RTL8366_SMI
++
+ endif # PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -20,6 +20,9 @@ obj-$(CONFIG_IP17XX_PHY)     += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY)     += realtek.o
+ obj-$(CONFIG_AR8216_PHY)      += ar8216.o
+ obj-$(CONFIG_RTL8306_PHY)     += rtl8306.o
++obj-$(CONFIG_RTL8366_SMI)     += rtl8366_smi.o
++obj-$(CONFIG_RTL8366S_PHY)    += rtl8366s.o
++obj-$(CONFIG_RTL8366RB_PHY)   += rtl8366rb.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY)               += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG)    += mdio-bitbang.o