generic: add preliminary 3.19 support
[15.05/openwrt.git] / target / linux / generic / patches-3.19 / 733-phy_mvsw61xx.patch
diff --git a/target/linux/generic/patches-3.19/733-phy_mvsw61xx.patch b/target/linux/generic/patches-3.19/733-phy_mvsw61xx.patch
new file mode 100644 (file)
index 0000000..041d168
--- /dev/null
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -143,6 +143,10 @@ config MVSWITCH_PHY
+       tristate "Driver for Marvell 88E6060 switches"
+       select ETHERNET_PACKET_MANGLE
++config MVSW61XX_PHY
++      tristate "Driver for Marvell 88E6171/6172 switches"
++      select SWCONFIG
++
+ config IP17XX_PHY
+       tristate "Driver for IC+ IP17xx switches"
+       select SWCONFIG
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -20,6 +20,7 @@ obj-$(CONFIG_BCM87XX_PHY)    += bcm87xx.o
+ obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
+ obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
++obj-$(CONFIG_MVSW61XX_PHY)    += mvsw61xx.o
+ obj-$(CONFIG_IP17XX_PHY)      += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY)     += realtek.o
+ obj-$(CONFIG_AR8216_PHY)      += ar8216.o ar8327.o