generic/3.18: upgrade to 3.18.10
[15.05/openwrt.git] / target / linux / generic / patches-3.18 / 643-bridge_remove_ipv6_dependency.patch
index 05df907..3f0dcd3 100644 (file)
@@ -25,7 +25,7 @@
          Ethernet bridge, which means that the different Ethernet segments it
 --- a/net/ipv6/Makefile
 +++ b/net/ipv6/Makefile
-@@ -45,6 +45,7 @@ obj-y += addrconf_core.o exthdrs_core.o 
+@@ -45,6 +45,7 @@ obj-y += addrconf_core.o exthdrs_core.o
  obj-$(CONFIG_INET) += output_core.o protocol.o $(ipv6-offload)
  
  obj-$(subst m,y,$(CONFIG_IPV6)) += inet6_hashtables.o
@@ -52,7 +52,7 @@
  
  int __ipv6_get_lladdr(struct inet6_dev *idev, struct in6_addr *addr,
                      u32 banned_flags)
-@@ -5434,6 +5433,9 @@ int __init addrconf_init(void)
+@@ -5451,6 +5450,9 @@ int __init addrconf_init(void)
  
        ipv6_addr_label_rtnl_register();
  
@@ -62,7 +62,7 @@
        return 0;
  errout:
        rtnl_af_unregister(&inet6_ops);
-@@ -5453,6 +5455,9 @@ void addrconf_cleanup(void)
+@@ -5470,6 +5472,9 @@ void addrconf_cleanup(void)
        struct net_device *dev;
        int i;