kernel: remove 3.12 support since none of the targets is using it
[openwrt.git] / target / linux / generic / patches-3.12 / 720-phy_adm6996.patch
diff --git a/target/linux/generic/patches-3.12/720-phy_adm6996.patch b/target/linux/generic/patches-3.12/720-phy_adm6996.patch
deleted file mode 100644 (file)
index 65b206d..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -120,6 +120,13 @@ config MICREL_PHY
-       ---help---
-         Supports the KSZ9021, VSC8201, KS8001 PHYs.
-+config ADM6996_PHY
-+      tristate "Driver for ADM6996 switches"
-+      select SWCONFIG
-+      ---help---
-+        Currently supports the ADM6996FC and ADM6996M switches.
-+        Support for FC is very limited.
-+
- config FIXED_PHY
-       bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
-       depends on PHYLIB=y
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -17,6 +17,7 @@ obj-$(CONFIG_BROADCOM_PHY)   += broadcom.o
- obj-$(CONFIG_BCM63XX_PHY)     += bcm63xx.o
- obj-$(CONFIG_BCM87XX_PHY)     += bcm87xx.o
- obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
-+obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
- obj-$(CONFIG_REALTEK_PHY)     += realtek.o
- obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
- obj-$(CONFIG_FIXED_PHY)               += fixed.o