ar71xx: create more network configs from the uci-defaults script
[openwrt.git] / target / linux / generic / patches-2.6.36 / 921-gpio_spi_driver.patch
index 9c80f90..4de5a2a 100644 (file)
@@ -14,7 +14,7 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
  4 files changed, 334 insertions(+)
 
 --- /dev/null
-+++ linux-2.6.36-rc7/include/linux/spi/spi_gpio_old.h
++++ b/include/linux/spi/spi_gpio_old.h
 @@ -0,0 +1,73 @@
 +/*
 + * spi_gpio interface to platform code
@@ -90,7 +90,7 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
 +
 +#endif /* _LINUX_SPI_SPI_GPIO */
 --- /dev/null
-+++ linux-2.6.36-rc7/drivers/spi/spi_gpio_old.c
++++ b/drivers/spi/spi_gpio_old.c
 @@ -0,0 +1,251 @@
 +/*
 + * Bitbanging SPI bus driver using GPIO API
@@ -343,8 +343,8 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
 +MODULE_AUTHOR("Michael Buesch");
 +MODULE_DESCRIPTION("Platform independent GPIO bitbanging SPI driver");
 +MODULE_LICENSE("GPL v2");
---- linux-2.6.36-rc7.orig/drivers/spi/Kconfig
-+++ linux-2.6.36-rc7/drivers/spi/Kconfig
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
 @@ -143,6 +143,15 @@ config SPI_GPIO
          GPIO operations, you should be able to leverage that for better
          speed with a custom version of this driver; see the source code.
@@ -361,8 +361,8 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
  config SPI_IMX
        tristate "Freescale i.MX SPI controllers"
        depends on ARCH_MXC
---- linux-2.6.36-rc7.orig/drivers/spi/Makefile
-+++ linux-2.6.36-rc7/drivers/spi/Makefile
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
 @@ -23,6 +23,7 @@ obj-$(CONFIG_SPI_DW_PCI)             += dw_spi_pci.
  obj-$(CONFIG_SPI_DW_MMIO)             += dw_spi_mmio.o
  obj-$(CONFIG_SPI_EP93XX)              += ep93xx_spi.o