rename target/linux/generic-2.6 to generic
[openwrt.git] / target / linux / generic / patches-2.6.31 / 680-phy_ar8216.patch
diff --git a/target/linux/generic/patches-2.6.31/680-phy_ar8216.patch b/target/linux/generic/patches-2.6.31/680-phy_ar8216.patch
new file mode 100644 (file)
index 0000000..d9d3ce7
--- /dev/null
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -100,6 +100,10 @@ config IP175C_PHY
+       tristate "Driver for IC+ IP175C/IP178C switches"
+       select SWCONFIG
++config AR8216_PHY
++      tristate "Driver for Atheros AR8216 switches"
++      select SWCONFIG
++
+ config FIXED_PHY
+       bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+       depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -17,6 +17,7 @@ obj-$(CONFIG_ADM6996_PHY)    += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
+ obj-$(CONFIG_IP175C_PHY)      += ip175c.o
+ obj-$(CONFIG_REALTEK_PHY)     += realtek.o
++obj-$(CONFIG_AR8216_PHY)      += ar8216.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY)               += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG)    += mdio-bitbang.o