rename target/linux/generic-2.6 to generic
[openwrt.git] / target / linux / generic / patches-2.6.30 / 400-ledtrig_morse.patch
diff --git a/target/linux/generic/patches-2.6.30/400-ledtrig_morse.patch b/target/linux/generic/patches-2.6.30/400-ledtrig_morse.patch
new file mode 100644 (file)
index 0000000..2754ed6
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -295,4 +295,8 @@ config LEDS_TRIGGER_DEFAULT_ON
+ comment "iptables trigger is under Netfilter config (LED target)"
+       depends on LEDS_TRIGGERS
++config LEDS_TRIGGER_MORSE
++      tristate "LED Morse Trigger"
++      depends on LEDS_TRIGGERS
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -38,3 +38,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += 
+ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT)  += ledtrig-backlight.o
+ obj-$(CONFIG_LEDS_TRIGGER_GPIO)               += ledtrig-gpio.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE)      += ledtrig-morse.o