Add bootloader specific code, need to fix bootloader detection code as well
[openwrt.git] / target / linux / brcm63xx-2.6 / patches / 020-bcmdrivers.patch
index 7efed28..5d6d6c9 100644 (file)
@@ -1,6 +1,6 @@
 diff -urN linux-2.6.17/bcmdrivers/opensource/char/serial/impl1/bcm63xx_cons.c linux-2.6.17-brcm63xx/bcmdrivers/opensource/char/serial/impl1/bcm63xx_cons.c
 --- linux-2.6.17/bcmdrivers/opensource/char/serial/impl1/bcm63xx_cons.c        1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/char/serial/impl1/bcm63xx_cons.c       2006-07-25 12:57:09.000000000 +0200
++++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/char/serial/impl1/bcm63xx_cons.c       2006-08-03 16:42:38.000000000 +0200
 @@ -0,0 +1,1056 @@
 +/*
 +<:copyright-gpl 
@@ -1060,7 +1060,7 @@ diff -urN linux-2.6.17/bcmdrivers/opensource/char/serial/impl1/bcm63xx_cons.c li
 +console_initcall(bcm63xx_console_init);
 diff -urN linux-2.6.17/bcmdrivers/opensource/char/serial/impl1/Makefile linux-2.6.17-brcm63xx/bcmdrivers/opensource/char/serial/impl1/Makefile
 --- linux-2.6.17/bcmdrivers/opensource/char/serial/impl1/Makefile      1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/char/serial/impl1/Makefile     2006-07-25 10:43:50.000000000 +0200
++++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/char/serial/impl1/Makefile     2006-08-03 16:42:38.000000000 +0200
 @@ -0,0 +1,13 @@
 +# File: bcmdrivers/opensource/char/serial
 +#
@@ -1077,7 +1077,7 @@ diff -urN linux-2.6.17/bcmdrivers/opensource/char/serial/impl1/Makefile linux-2.
 +
 diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/6338_intr.h linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/6338_intr.h
 --- linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/6338_intr.h    1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/6338_intr.h   2006-07-25 10:44:46.000000000 +0200
++++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/6338_intr.h   2006-08-03 16:42:38.000000000 +0200
 @@ -0,0 +1,64 @@
 +/*
 +<:copyright-gpl 
@@ -1145,7 +1145,7 @@ diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/6338_intr.h linux-
 +
 diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/6338_map_part.h linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/6338_map_part.h
 --- linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/6338_map_part.h        1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/6338_map_part.h       2006-07-25 10:44:59.000000000 +0200
++++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/6338_map_part.h       2006-08-03 16:42:38.000000000 +0200
 @@ -0,0 +1,334 @@
 +/*
 +<:copyright-gpl 
@@ -1483,7 +1483,7 @@ diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/6338_map_part.h li
 +
 diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/6345_intr.h linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/6345_intr.h
 --- linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/6345_intr.h    1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/6345_intr.h   2006-07-25 10:45:09.000000000 +0200
++++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/6345_intr.h   2006-08-03 16:42:38.000000000 +0200
 @@ -0,0 +1,72 @@
 +/*
 +<:copyright-gpl 
@@ -1559,7 +1559,7 @@ diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/6345_intr.h linux-
 +
 diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/6345_map_part.h linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/6345_map_part.h
 --- linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/6345_map_part.h        1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/6345_map_part.h       2006-07-25 10:45:19.000000000 +0200
++++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/6345_map_part.h       2006-08-03 16:42:38.000000000 +0200
 @@ -0,0 +1,163 @@
 +/*
 +<:copyright-gpl 
@@ -1726,7 +1726,7 @@ diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/6345_map_part.h li
 +
 diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/6348_intr.h linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/6348_intr.h
 --- linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/6348_intr.h    1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/6348_intr.h   2006-07-25 10:45:33.000000000 +0200
++++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/6348_intr.h   2006-08-03 16:42:38.000000000 +0200
 @@ -0,0 +1,74 @@
 +/*
 +<:copyright-gpl 
@@ -1804,7 +1804,7 @@ diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/6348_intr.h linux-
 +
 diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/6348_map_part.h linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/6348_map_part.h
 --- linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/6348_map_part.h        1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/6348_map_part.h       2006-07-25 10:44:21.000000000 +0200
++++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/6348_map_part.h       2006-08-03 16:42:38.000000000 +0200
 @@ -0,0 +1,500 @@
 +/*
 +<:copyright-gpl 
@@ -2308,7 +2308,7 @@ diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/6348_map_part.h li
 +
 diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/bcm_intr.h linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/bcm_intr.h
 --- linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/bcm_intr.h     1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/bcm_intr.h    2006-07-25 10:43:50.000000000 +0200
++++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/bcm_intr.h    2006-08-03 16:42:38.000000000 +0200
 @@ -0,0 +1,59 @@
 +/*
 +<:copyright-gpl 
@@ -2371,7 +2371,7 @@ diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/bcm_intr.h linux-2
 +#endif
 diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/bcm_map_part.h linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/bcm_map_part.h
 --- linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/bcm_map_part.h 1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/bcm_map_part.h        2006-07-25 10:43:50.000000000 +0200
++++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/bcm_map_part.h        2006-08-03 16:42:38.000000000 +0200
 @@ -0,0 +1,34 @@
 +/*
 +<:copyright-gpl 
@@ -2409,7 +2409,7 @@ diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/bcm_map_part.h lin
 +
 diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/bcmpci.h linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/bcmpci.h
 --- linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/bcmpci.h       1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/bcmpci.h      2006-07-25 10:43:50.000000000 +0200
++++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/bcmpci.h      2006-08-03 16:42:38.000000000 +0200
 @@ -0,0 +1,87 @@
 +/*
 +<:copyright-gpl 
@@ -2500,7 +2500,7 @@ diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/bcmpci.h linux-2.6
 +#endif
 diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/bcmTag.h linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/bcmTag.h
 --- linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/bcmTag.h       1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/bcmTag.h      2006-07-25 10:43:50.000000000 +0200
++++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/bcmTag.h      2006-08-03 16:42:38.000000000 +0200
 @@ -0,0 +1,153 @@
 +/*
 +<:copyright-gpl 
@@ -2657,7 +2657,7 @@ diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/bcmTag.h linux-2.6
 +
 diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/bcmtypes.h linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/bcmtypes.h
 --- linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/bcmtypes.h     1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/bcmtypes.h    2006-07-25 10:43:50.000000000 +0200
++++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/bcmtypes.h    2006-08-03 16:42:38.000000000 +0200
 @@ -0,0 +1,163 @@
 +/*
 +<:copyright-gpl 
@@ -2824,8 +2824,8 @@ diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/bcmtypes.h linux-2
 +#endif
 diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/board.h linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/board.h
 --- linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/board.h        1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/board.h       2006-07-25 11:00:10.000000000 +0200
-@@ -0,0 +1,368 @@
++++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/include/bcm963xx/board.h       2006-08-03 16:42:46.000000000 +0200
+@@ -0,0 +1,374 @@
 +/*
 +<:copyright-gpl 
 + Copyright 2002 Broadcom Corp. All Rights Reserved. 
@@ -3085,6 +3085,8 @@ diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/board.h linux-2.6.
 +    kLedPPP,
 +    kLedVoip,
 +    kLedSes,
++    kLedLan,
++    kLedSelfTest,
 +    kLedEnd,                // NOTE: Insert the new led name before this one.  Alway stay at the end.
 +} BOARD_LED_NAME;
 +
@@ -3191,12 +3193,16 @@ diff -urN linux-2.6.17/bcmdrivers/opensource/include/bcm963xx/board.h linux-2.6.
 +void kerSysWakeupMonitorTask( void );
 +#endif
 +
++#define BOOT_CFE     0
++#define BOOT_REDBOOT 1
++
++extern int boot_loader_type;
 +
 +#endif /* _BOARD_H */
 +
 diff -urN linux-2.6.17/bcmdrivers/opensource/Makefile linux-2.6.17-brcm63xx/bcmdrivers/opensource/Makefile
 --- linux-2.6.17/bcmdrivers/opensource/Makefile        1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/Makefile       2006-07-25 10:43:50.000000000 +0200
++++ linux-2.6.17-brcm63xx/bcmdrivers/opensource/Makefile       2006-08-03 16:42:38.000000000 +0200
 @@ -0,0 +1,20 @@
 +# File: modules/drivers/Makefile
 +#