fill in the kernel version info for every target, move the kernel tarball md5sums...
[openwrt.git] / target / linux / brcm63xx-2.6 / Makefile
index d7b71c8..a8c7a3c 100644 (file)
@@ -9,29 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM963xx
-FEATURES:=squashfs jffs2 broken
+FEATURES:=squashfs jffs2 broken usb atm
+
+LINUX_VERSION:=2.6.21.5
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
        (e.g. Inventel Livebox, Siemens SE515)
 endef
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
-
 include $(INCLUDE_DIR)/kernel-build.mk
 
-define Profile/Broadcom
-  NAME:=Broadcom WiFi (default)
-  PACKAGES:=kmod-net-bcm43xx
-endef
-$(eval $(call Profile,Broadcom))
-
-define Profile/Atheros
-  NAME:=Atheros WiFi
-  PACKAGES:=kmod-madwifi
-endef
-$(eval $(call Profile,Atheros))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))