brcm47xx: change generic profiles
[openwrt.git] / target / linux / brcm47xx / profiles / 210-Broadcom-tg3-b43.mk
diff --git a/target/linux/brcm47xx/profiles/210-Broadcom-tg3-b43.mk b/target/linux/brcm47xx/profiles/210-Broadcom-tg3-b43.mk
new file mode 100644 (file)
index 0000000..a0bece9
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2007-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-tg3-b43
+  NAME:=Broadcom SoC, tg3 Ethernet, BCM43xx WiFi (b43)
+  PACKAGES:=kmod-b43 kmod-tg3
+endef
+
+define Profile/Broadcom-tg3-b43/Description
+       Package set compatible with hardware Broadcom BCM4705/BCM4785
+       SoCs with Broadcom BCM43xx Wifi cards using the mac80211 and b43
+       driver and tg3 Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-tg3-b43))
+