brcm47xx: move current target to "generic" subtarget
[15.05/openwrt.git] / target / linux / brcm47xx / generic / profiles / 201-Broadcom-b44-wl.mk
diff --git a/target/linux/brcm47xx/generic/profiles/201-Broadcom-b44-wl.mk b/target/linux/brcm47xx/generic/profiles/201-Broadcom-b44-wl.mk
new file mode 100644 (file)
index 0000000..f974c00
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-b44-wl
+  NAME:=Broadcom SoC, b44 Ethernet, BCM43xx WiFi (wl, proprietary)
+  PACKAGES:=-wpad-mini kmod-b44 kmod-brcm-wl wlc nas
+endef
+
+define Profile/Broadcom-b44-wl/Description
+       Package set compatible with hardware older Broadcom BCM47xx or BCM535x
+       SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
+       wireless "wl" driver and b44 Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-b44-wl))
+