brcm2708: remove linux 4.1 support
[openwrt.git] / target / linux / brcm2708 / patches-4.1 / 0044-Add-IQaudIO-Sound-Card-support-for-Raspberry-Pi.patch
diff --git a/target/linux/brcm2708/patches-4.1/0044-Add-IQaudIO-Sound-Card-support-for-Raspberry-Pi.patch b/target/linux/brcm2708/patches-4.1/0044-Add-IQaudIO-Sound-Card-support-for-Raspberry-Pi.patch
deleted file mode 100644 (file)
index 177687d..0000000
+++ /dev/null
@@ -1,201 +0,0 @@
-From f8fb55caae97e04ab68a955eb8946dbee37cd6fe Mon Sep 17 00:00:00 2001
-From: Gordon Garrity <gordon@iqaudio.com>
-Date: Sat, 8 Mar 2014 16:56:57 +0000
-Subject: [PATCH 044/222] Add IQaudIO Sound Card support for Raspberry Pi
-
-Set a limit of 0dB on Digital Volume Control
-
-The main volume control in the PCM512x DAC has a range up to
-+24dB. This is dangerously loud and can potentially cause massive
-clipping in the output stages. Therefore this sets a sensible
-limit of 0dB for this control.
----
- arch/arm/mach-bcm2708/bcm2708.c |  21 ++++++++
- sound/soc/bcm/Kconfig           |   7 +++
- sound/soc/bcm/Makefile          |   2 +
- sound/soc/bcm/iqaudio-dac.c     | 117 ++++++++++++++++++++++++++++++++++++++++
- 4 files changed, 147 insertions(+)
- create mode 100644 sound/soc/bcm/iqaudio-dac.c
-
---- a/arch/arm/mach-bcm2708/bcm2708.c
-+++ b/arch/arm/mach-bcm2708/bcm2708.c
-@@ -681,6 +681,22 @@ static struct platform_device snd_pcm179
- };
- #endif
-+
-+#if defined(CONFIG_SND_BCM2708_SOC_IQAUDIO_DAC) || defined(CONFIG_SND_BCM2708_SOC_IQAUDIO_DAC_MODULE)
-+static struct platform_device snd_rpi_iqaudio_dac_device = {
-+        .name = "snd-rpi-iqaudio-dac",
-+        .id = 0,
-+        .num_resources = 0,
-+};
-+
-+// Use the actual device name rather than generic driver name
-+static struct i2c_board_info __initdata snd_pcm512x_i2c_devices[] = {
-+      {
-+              I2C_BOARD_INFO("pcm5122", 0x4c)
-+      },
-+};
-+#endif
-+
- int __init bcm_register_device(struct platform_device *pdev)
- {
-       int ret;
-@@ -864,6 +880,11 @@ void __init bcm2708_init(void)
-         bcm_register_device_dt(&snd_pcm1794a_codec_device);
- #endif
-+#if defined(CONFIG_SND_BCM2708_SOC_IQAUDIO_DAC) || defined(CONFIG_SND_BCM2708_SOC_IQAUDIO_DAC_MODULE)
-+        bcm_register_device_dt(&snd_rpi_iqaudio_dac_device);
-+        i2c_register_board_info_dt(1, snd_pcm512x_i2c_devices, ARRAY_SIZE(snd_pcm512x_i2c_devices));
-+#endif
-+
-       if (!use_dt) {
-               for (i = 0; i < ARRAY_SIZE(amba_devs); i++) {
-                       struct amba_device *d = amba_devs[i];
---- a/sound/soc/bcm/Kconfig
-+++ b/sound/soc/bcm/Kconfig
-@@ -39,3 +39,10 @@ config SND_BCM2708_SOC_RPI_DAC
-         select SND_SOC_PCM1794A
-         help
-          Say Y or M if you want to add support for RPi-DAC.
-+
-+config SND_BCM2708_SOC_IQAUDIO_DAC
-+      tristate "Support for IQaudIO-DAC"
-+      depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
-+      select SND_SOC_PCM512x_I2C
-+      help
-+        Say Y or M if you want to add support for IQaudIO-DAC.
---- a/sound/soc/bcm/Makefile
-+++ b/sound/soc/bcm/Makefile
-@@ -12,7 +12,9 @@ obj-$(CONFIG_SND_BCM2708_SOC_I2S) += snd
- snd-soc-hifiberry-dac-objs := hifiberry_dac.o
- snd-soc-hifiberry-digi-objs := hifiberry_digi.o
- snd-soc-rpi-dac-objs := rpi-dac.o
-+snd-soc-iqaudio-dac-objs := iqaudio-dac.o
- obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DAC) += snd-soc-hifiberry-dac.o
- obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DIGI) += snd-soc-hifiberry-digi.o
- obj-$(CONFIG_SND_BCM2708_SOC_RPI_DAC) += snd-soc-rpi-dac.o
-+obj-$(CONFIG_SND_BCM2708_SOC_IQAUDIO_DAC) += snd-soc-iqaudio-dac.o
---- /dev/null
-+++ b/sound/soc/bcm/iqaudio-dac.c
-@@ -0,0 +1,117 @@
-+/*
-+ * ASoC Driver for IQaudIO DAC
-+ *
-+ * Author:    Florian Meier <florian.meier@koalo.de>
-+ *            Copyright 2013
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License
-+ * version 2 as published by the Free Software Foundation.
-+ *
-+ * This program is distributed in the hope that it will be useful, but
-+ * WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-+ * General Public License for more details.
-+ */
-+
-+#include <linux/module.h>
-+#include <linux/platform_device.h>
-+
-+#include <sound/core.h>
-+#include <sound/pcm.h>
-+#include <sound/pcm_params.h>
-+#include <sound/soc.h>
-+#include <sound/jack.h>
-+
-+static int snd_rpi_iqaudio_dac_init(struct snd_soc_pcm_runtime *rtd)
-+{
-+      int ret;
-+      struct snd_soc_card *card = rtd->card;
-+      struct snd_soc_codec *codec = rtd->codec;
-+
-+      ret = snd_soc_limit_volume(codec, "Digital Playback Volume", 207);
-+      if (ret < 0)
-+              dev_warn(card->dev, "Failed to set volume limit: %d\n", ret);
-+
-+      return 0;
-+}
-+
-+static int snd_rpi_iqaudio_dac_hw_params(struct snd_pcm_substream *substream,
-+                                     struct snd_pcm_hw_params *params)
-+{
-+      struct snd_soc_pcm_runtime *rtd = substream->private_data;
-+// NOT USED   struct snd_soc_dai *codec_dai = rtd->codec_dai;
-+// NOT USED   struct snd_soc_codec *codec = rtd->codec;
-+      struct snd_soc_dai *cpu_dai = rtd->cpu_dai;
-+
-+      unsigned int sample_bits =
-+              snd_pcm_format_physical_width(params_format(params));
-+
-+      return snd_soc_dai_set_bclk_ratio(cpu_dai, sample_bits * 2);
-+}
-+
-+/* machine stream operations */
-+static struct snd_soc_ops snd_rpi_iqaudio_dac_ops = {
-+      .hw_params = snd_rpi_iqaudio_dac_hw_params,
-+};
-+
-+static struct snd_soc_dai_link snd_rpi_iqaudio_dac_dai[] = {
-+{
-+      .name           = "IQaudIO DAC",
-+      .stream_name    = "IQaudIO DAC HiFi",
-+      .cpu_dai_name   = "bcm2708-i2s.0",
-+      .codec_dai_name = "pcm512x-hifi",
-+      .platform_name  = "bcm2708-i2s.0",
-+      .codec_name     = "pcm512x.1-004c",
-+      .dai_fmt        = SND_SOC_DAIFMT_I2S | SND_SOC_DAIFMT_NB_NF |
-+                              SND_SOC_DAIFMT_CBS_CFS,
-+      .ops            = &snd_rpi_iqaudio_dac_ops,
-+      .init           = snd_rpi_iqaudio_dac_init,
-+},
-+};
-+
-+/* audio machine driver */
-+static struct snd_soc_card snd_rpi_iqaudio_dac = {
-+      .name         = "IQaudIODAC",
-+      .dai_link     = snd_rpi_iqaudio_dac_dai,
-+      .num_links    = ARRAY_SIZE(snd_rpi_iqaudio_dac_dai),
-+};
-+
-+static int snd_rpi_iqaudio_dac_probe(struct platform_device *pdev)
-+{
-+      int ret = 0;
-+
-+      snd_rpi_iqaudio_dac.dev = &pdev->dev;
-+      ret = snd_soc_register_card(&snd_rpi_iqaudio_dac);
-+      if (ret)
-+              dev_err(&pdev->dev,
-+                      "snd_soc_register_card() failed: %d\n", ret);
-+
-+      return ret;
-+}
-+
-+static int snd_rpi_iqaudio_dac_remove(struct platform_device *pdev)
-+{
-+      return snd_soc_unregister_card(&snd_rpi_iqaudio_dac);
-+}
-+
-+static const struct of_device_id iqaudio_of_match[] = {
-+      { .compatible = "iqaudio,iqaudio-dac", },
-+      {},
-+};
-+
-+static struct platform_driver snd_rpi_iqaudio_dac_driver = {
-+      .driver = {
-+              .name   = "snd-rpi-iqaudio-dac",
-+              .owner  = THIS_MODULE,
-+              .of_match_table = iqaudio_of_match,
-+      },
-+      .probe          = snd_rpi_iqaudio_dac_probe,
-+      .remove         = snd_rpi_iqaudio_dac_remove,
-+};
-+
-+module_platform_driver(snd_rpi_iqaudio_dac_driver);
-+
-+MODULE_AUTHOR("Florian Meier <florian.meier@koalo.de>");
-+MODULE_DESCRIPTION("ASoC Driver for IQAudio DAC");
-+MODULE_LICENSE("GPL v2");