[brcm2708] adds target used by rapsberry pi
[openwrt.git] / target / linux / brcm2708 / modules.mk
diff --git a/target/linux/brcm2708/modules.mk b/target/linux/brcm2708/modules.mk
new file mode 100644 (file)
index 0000000..e8a2bff
--- /dev/null
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/sound-arm-bcm2835
+  TITLE:=Broadcom 2708,2835 SoC sound support
+  KCONFIG:= \
+       CONFIG_SND_ARM=y \
+       CONFIG_SND_BCM2835 \
+       CONFIG_SND_ARMAACI=n
+  FILES:= \
+       $(LINUX_DIR)/sound/arm/snd-bcm2835.ko
+  AUTOLOAD:=$(call AutoLoad,68,snd-bcm2835)
+  DEPENDS:=@TARGET_brcm2708
+  $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-arm-bcm2835/description
+  This package contains the Broadcom 2708/2835 sound driver
+endef
+
+$(eval $(call KernelPackage,sound-arm-bcm2835))
+