ar71xx: nuke clocksource init patches, it is not required since 2.6.27
[openwrt.git] / target / linux / brcm-2.4 / patches / 004-flash.patch
index 0046c37..cbcf0da 100644 (file)
@@ -1,7 +1,15 @@
-Index: linux-2.4.35.4/drivers/mtd/devices/Config.in
-===================================================================
---- linux-2.4.35.4.orig/drivers/mtd/devices/Config.in  2007-12-15 05:19:36.210484556 +0100
-+++ linux-2.4.35.4/drivers/mtd/devices/Config.in       2007-12-15 05:20:14.656675480 +0100
+--- a/arch/mips/bcm947xx/Makefile
++++ b/arch/mips/bcm947xx/Makefile
+@@ -11,6 +11,7 @@ export-objs     := export.o
+ obj-y         := prom.o setup.o time.o sbmips.o gpio.o
+ obj-y         += nvram.o cfe_env.o hndpmu.o
+ obj-y         += sbutils.o utils.o bcmsrom.o hndchipc.o
++obj-y         += sflash.o
+ obj-$(CONFIG_PCI) += sbpci.o pcibios.o
+ obj-y                 += export.o
+--- a/drivers/mtd/devices/Config.in
++++ b/drivers/mtd/devices/Config.in
 @@ -5,6 +5,7 @@
  mainmenu_option next_comment
  
@@ -10,10 +18,8 @@ Index: linux-2.4.35.4/drivers/mtd/devices/Config.in
  dep_tristate '  Ramix PMC551 PCI Mezzanine RAM card support' CONFIG_MTD_PMC551 $CONFIG_MTD $CONFIG_PCI
  if [ "$CONFIG_MTD_PMC551" = "y" -o  "$CONFIG_MTD_PMC551" = "m" ]; then
     bool '    PMC551 256M DRAM Bugfix' CONFIG_MTD_PMC551_BUGFIX
-Index: linux-2.4.35.4/drivers/mtd/devices/Makefile
-===================================================================
---- linux-2.4.35.4.orig/drivers/mtd/devices/Makefile   2007-12-15 05:19:36.218485012 +0100
-+++ linux-2.4.35.4/drivers/mtd/devices/Makefile        2007-12-15 05:20:14.660675705 +0100
+--- a/drivers/mtd/devices/Makefile
++++ b/drivers/mtd/devices/Makefile
 @@ -3,6 +3,8 @@
  #
  # $Id: Makefile,v 1.4 2001/06/26 21:10:05 spse Exp $
@@ -23,7 +29,7 @@ Index: linux-2.4.35.4/drivers/mtd/devices/Makefile
  O_TARGET      := devlink.o
  
  #                       *** BIG UGLY NOTE ***
-@@ -12,6 +14,7 @@
+@@ -12,6 +14,7 @@ O_TARGET     := devlink.o
  # here where previously there was none.  We now have to ensure that
  # doc200[01].o are linked before docprobe.o
  
@@ -31,11 +37,9 @@ Index: linux-2.4.35.4/drivers/mtd/devices/Makefile
  obj-$(CONFIG_MTD_DOC1000)     += doc1000.o
  obj-$(CONFIG_MTD_DOC2000)     += doc2000.o
  obj-$(CONFIG_MTD_DOC2001)     += doc2001.o
-Index: linux-2.4.35.4/drivers/mtd/maps/Config.in
-===================================================================
---- linux-2.4.35.4.orig/drivers/mtd/maps/Config.in     2007-12-15 05:19:44.950982647 +0100
-+++ linux-2.4.35.4/drivers/mtd/maps/Config.in  2007-12-15 05:20:14.664675934 +0100
-@@ -48,6 +48,7 @@
+--- a/drivers/mtd/maps/Config.in
++++ b/drivers/mtd/maps/Config.in
+@@ -48,6 +48,7 @@ if [ "$CONFIG_PPC" = "y" ]; then
  fi
  
  if [ "$CONFIG_MIPS" = "y" ]; then
@@ -43,10 +47,8 @@ Index: linux-2.4.35.4/drivers/mtd/maps/Config.in
     dep_tristate '  Pb1000 MTD support' CONFIG_MTD_PB1000 $CONFIG_MIPS_PB1000
     dep_tristate '  Pb1500 MTD support' CONFIG_MTD_PB1500 $CONFIG_MIPS_PB1500
     dep_tristate '  Pb1100 MTD support' CONFIG_MTD_PB1100 $CONFIG_MIPS_PB1100
-Index: linux-2.4.35.4/drivers/mtd/maps/Makefile
-===================================================================
---- linux-2.4.35.4.orig/drivers/mtd/maps/Makefile      2007-12-15 05:19:44.954982876 +0100
-+++ linux-2.4.35.4/drivers/mtd/maps/Makefile   2007-12-15 05:20:14.664675934 +0100
+--- a/drivers/mtd/maps/Makefile
++++ b/drivers/mtd/maps/Makefile
 @@ -3,6 +3,8 @@
  #
  # $Id: Makefile,v 1.37 2003/01/24 14:26:38 dwmw2 Exp $
@@ -56,7 +58,7 @@ Index: linux-2.4.35.4/drivers/mtd/maps/Makefile
  BELOW25               := $(shell echo $(PATCHLEVEL) | sed s/[1234]/y/)
  
  ifeq ($(BELOW25),y)
-@@ -10,6 +12,7 @@
+@@ -10,6 +12,7 @@ O_TARGET     := mapslink.o
  endif
  
  # Chip mappings