bcm53xx: remove linux 3.14 support
[15.05/openwrt.git] / target / linux / bcm53xx / patches-3.14 / 049-ARM-BCM5301X-Add-DT-for-Buffalo-WZR-1750DHP.patch
diff --git a/target/linux/bcm53xx/patches-3.14/049-ARM-BCM5301X-Add-DT-for-Buffalo-WZR-1750DHP.patch b/target/linux/bcm53xx/patches-3.14/049-ARM-BCM5301X-Add-DT-for-Buffalo-WZR-1750DHP.patch
deleted file mode 100644 (file)
index 01d85aa..0000000
+++ /dev/null
@@ -1,93 +0,0 @@
-From e336a14d2a2aa4431a8acc9eb3305b37f26fb696 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
-Date: Thu, 4 Dec 2014 10:22:58 +0100
-Subject: [PATCH] ARM: BCM5301X: Add DT for Buffalo WZR-1750DHP
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
-Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
----
- arch/arm/boot/dts/Makefile                        |  1 +
- arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts | 64 +++++++++++++++++++++++
- 2 files changed, 65 insertions(+)
- create mode 100644 arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
-
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -51,6 +51,7 @@ dtb-$(CONFIG_ARCH_BCM_MOBILE) += bcm1135
-       bcm28155-ap.dtb
- dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b.dtb
- dtb-$(CONFIG_ARCH_BCM_5301X) += \
-+      bcm4708-buffalo-wzr-1750dhp.dtb \
-       bcm4708-netgear-r6250.dtb \
-       bcm4708-netgear-r6300-v2.dtb
- dtb-$(CONFIG_ARCH_BERLIN) += \
---- /dev/null
-+++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
-@@ -0,0 +1,64 @@
-+/*
-+ * Broadcom BCM470X / BCM5301X ARM platform code.
-+ * DTS for Buffalo WZR-1750DHP
-+ *
-+ * Copyright (C) 2014 Rafał Miłecki <zajec5@gmail.com>
-+ *
-+ * Licensed under the GNU/GPL. See COPYING for details.
-+ */
-+
-+/dts-v1/;
-+
-+#include "bcm4708.dtsi"
-+
-+/ {
-+      compatible = "buffalo,wzr-1750dhp", "brcm,bcm4708";
-+      model = "Buffalo WZR-1750DHP (BCM4708)";
-+
-+      chosen {
-+              bootargs = "console=ttyS0,115200";
-+      };
-+
-+      memory {
-+              reg = <0x00000000 0x08000000>;
-+      };
-+
-+      gpio-keys {
-+              compatible = "gpio-keys";
-+              #address-cells = <1>;
-+              #size-cells = <0>;
-+              poll-interval = <200>;
-+
-+              restart {
-+                      label = "Reset";
-+                      linux,code = <KEY_RESTART>;
-+                      gpios = <&chipcommon 11 GPIO_ACTIVE_LOW>;
-+              };
-+
-+              aoss {
-+                      label = "AOSS";
-+                      linux,code = <KEY_WPS_BUTTON>;
-+                      gpios = <&chipcommon 12 GPIO_ACTIVE_LOW>;
-+              };
-+
-+              /* Commit mode set by switch? */
-+              mode {
-+                      label = "Mode";
-+                      linux,code = <KEY_SETUP>;
-+                      gpios = <&chipcommon 13 GPIO_ACTIVE_LOW>;
-+              };
-+
-+              /* Switch: AP mode */
-+              sw_ap {
-+                      label = "AP";
-+                      linux,code = <BTN_0>;
-+                      gpios = <&chipcommon 14 GPIO_ACTIVE_LOW>;
-+              };
-+
-+              eject {
-+                      label = "USB eject";
-+                      linux,code = <KEY_EJECTCD>;
-+                      gpios = <&chipcommon 15 GPIO_ACTIVE_LOW>;
-+              };
-+      };
-+};