only build avr32 u-boot if requested, fixes build failure in default config
[openwrt.git] / target / linux / avr32 / image / Makefile
index 2cef265..c74efbe 100644 (file)
@@ -8,13 +8,15 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-define Build/Clean
+ifneq ($(CONFIG_AVR32_UBOOT),)
+  define Build/Clean
        $(MAKE) -C u-boot clean
-endef
+  endef
 
-define Build/Compile
+  define Build/Compile
        $(MAKE) -C u-boot compile
-endef
+  endef
+endif
 
 define Image/Prepare
        cp $(LINUX_DIR)/arch/avr32/boot/images/uImage $(KDIR)/uImage