Rename 'atheros' target to 'ath25'
[15.05/openwrt.git] / target / linux / ath25 / Makefile
diff --git a/target/linux/ath25/Makefile b/target/linux/ath25/Makefile
new file mode 100644 (file)
index 0000000..b1baa2e
--- /dev/null
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=ath25
+BOARDNAME:=Atheros AR231x/AR5312
+FEATURES:=squashfs low_mem
+
+KERNEL_PATCHVER:=3.18
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
+
+define Target/Description
+       Build firmware images for Atheros SoC boards
+endef
+
+$(eval $(call BuildTarget))