brcm47xx: adjust the brcm4710 cache workaround code so that it does not break bcm4716...
[openwrt.git] / target / linux / ar71xx / profiles / ubnt.mk
index ac9ef36..a7fd9a2 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/UBNTRS
        NAME:=Ubiquiti RouterStation
-       PACKAGES:=kmod-usb-ohci kmod-usb2
+       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
 endef
 
 define Profile/UBNTRS/Description
@@ -15,3 +15,25 @@ define Profile/UBNTRS/Description
 endef
 
 $(eval $(call Profile,UBNTRS))
+
+define Profile/UBNTRSPRO
+       NAME:=Ubiquiti RouterStation Pro
+       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/UBNTRSPRO/Description
+       Package set optimized for the Ubiquiti RouterStation Pro.
+endef
+
+$(eval $(call Profile,UBNTRSPRO))
+
+define Profile/UBNT
+       NAME:=Ubiquiti Products
+       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/UBNT/Description
+       Build images for all Ubiquiti products (including LS-SR71, RouterStation and RouterStation Pro)
+endef
+
+$(eval $(call Profile,UBNT))