brcm47xx: adjust the brcm4710 cache workaround code so that it does not break bcm4716...
[openwrt.git] / target / linux / ar71xx / profiles / d-link.mk
index 460900d..bf99e09 100644 (file)
@@ -5,9 +5,21 @@
 # See /LICENSE for more information.
 #
 
+define Profile/DIR600A1
+       NAME:=D-Link DIR-600 rev. A1
+       PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/DIR600A1/Description
+       Package set optimized for the D-Link DIR-600 rev. A1.
+endef
+
+$(eval $(call Profile,DIR600A1))
+
+
 define Profile/DIR615C1
        NAME:=D-Link DIR-615 rev. C1
-       PACKAGES:=kmod-ath9k hostapd-mini
+       PACKAGES:=kmod-ath9k wpad-mini
 endef
 
 define Profile/DIR615C1/Description
@@ -15,3 +27,15 @@ define Profile/DIR615C1/Description
 endef
 
 $(eval $(call Profile,DIR615C1))
+
+
+define Profile/DIR825B1
+       NAME:=D-Link DIR-825 rev. B1
+       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
+endef
+
+define Profile/DIR825B1/Description
+       Package set optimized for the D-Link DIR-825 rev. B1.
+endef
+
+$(eval $(call Profile,DIR825B1))