brcm47xx: adjust the brcm4710 cache workaround code so that it does not break bcm4716...
[openwrt.git] / target / linux / ar71xx / profiles / atheros.mk
index c809311..4ce0e60 100644 (file)
@@ -18,7 +18,8 @@ $(eval $(call Profile,AP81))
 
 define Profile/AP83
        NAME:=Atheros AP83 reference board
-       PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2
+       PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2 \
+                 vsc7385-ucode-ap83 vsc7395-ucode-ap83
 endef
 
 define Profile/AP83/Description
@@ -40,7 +41,8 @@ $(eval $(call Profile,PB42))
 
 define Profile/PB44
        NAME:=Atheros PB44 reference board
-       PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb-ohci kmod-usb2
+       PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb-ohci kmod-usb2 \
+                 vsc7385-ucode-pb44 vsc7395-ucode-pb44
 endef
 
 define Profile/PB44/Description
@@ -48,3 +50,14 @@ define Profile/PB44/Description
 endef
 
 $(eval $(call Profile,PB44))
+
+define Profile/PB92
+       NAME:=Atheros PB92 reference board
+       PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2
+endef
+
+define Profile/PB92/Description
+       Package set optimized for the Atheros PB92 reference board.
+endef
+
+$(eval $(call Profile,PB92))