ar71xx: nuke 3.3 support
[openwrt.git] / target / linux / ar71xx / patches-3.3 / 611-MIPS-ath79-CAP4200AG-support.patch
diff --git a/target/linux/ar71xx/patches-3.3/611-MIPS-ath79-CAP4200AG-support.patch b/target/linux/ar71xx/patches-3.3/611-MIPS-ath79-CAP4200AG-support.patch
deleted file mode 100644 (file)
index 39cef42..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
---- a/arch/mips/ath79/Kconfig
-+++ b/arch/mips/ath79/Kconfig
-@@ -403,6 +403,16 @@ config ATH79_MACH_RW2458N
-       select ATH79_DEV_M25P80
-       select ATH79_DEV_USB
-+config ATH79_MACH_CAP4200AG
-+      bool "Senao CAP4200AG support"
-+      select SOC_AR934X
-+      select ATH79_DEV_AP9X_PCI if PCI
-+      select ATH79_DEV_ETH
-+      select ATH79_DEV_GPIO_BUTTONS
-+      select ATH79_DEV_LEDS_GPIO
-+      select ATH79_DEV_M25P80
-+      select ATH79_DEV_WMAC
-+
- config ATH79_MACH_EAP7660D
-       bool "Senao EAP7660D support"
-       select SOC_AR71XX
---- a/arch/mips/ath79/machtypes.h
-+++ b/arch/mips/ath79/machtypes.h
-@@ -29,6 +29,7 @@ enum ath79_mach_type {
-       ATH79_MACH_AP83,                /* Atheros AP83 */
-       ATH79_MACH_AP96,                /* Atheros AP96 */
-       ATH79_MACH_AW_NR580,            /* AzureWave AW-NR580 */
-+      ATH79_MACH_CAP4200AG,           /* Senao CAP4200AG */
-       ATH79_MACH_DB120,               /* Atheros DB120 reference board */
-       ATH79_MACH_PB44,                /* Atheros PB44 reference board */
-       ATH79_MACH_DIR_600_A1,          /* D-Link DIR-600 rev. A1 */
---- a/arch/mips/ath79/Makefile
-+++ b/arch/mips/ath79/Makefile
-@@ -49,6 +49,7 @@ obj-$(CONFIG_ATH79_MACH_AP81)                += mach-a
- obj-$(CONFIG_ATH79_MACH_AP83)         += mach-ap83.o
- obj-$(CONFIG_ATH79_MACH_AP96)         += mach-ap96.o
- obj-$(CONFIG_ATH79_MACH_AW_NR580)     += mach-aw-nr580.o
-+obj-$(CONFIG_ATH79_MACH_CAP4200AG)    += mach-cap4200ag.o
- obj-$(CONFIG_ATH79_MACH_DB120)                += mach-db120.o
- obj-$(CONFIG_ATH79_MACH_DIR_600_A1)   += mach-dir-600-a1.o
- obj-$(CONFIG_ATH79_MACH_DIR_615_C1)   += mach-dir-615-c1.o