kernel: add missing config options
[openwrt.git] / target / linux / ar71xx / patches-3.10 / 610-MIPS-ath79-openwrt-machines.patch
index 12e24f0..a19f52c 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-3.10/arch/mips/ath79/machtypes.h
-===================================================================
---- linux-3.10.orig/arch/mips/ath79/machtypes.h        2013-07-11 22:29:04.592988418 +0200
-+++ linux-3.10/arch/mips/ath79/machtypes.h     2013-07-11 22:42:15.781006779 +0200
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
 @@ -16,22 +16,125 @@
  
  enum ath79_mach_type {
@@ -128,11 +126,9 @@ Index: linux-3.10/arch/mips/ath79/machtypes.h
  };
  
  #endif /* _ATH79_MACHTYPE_H */
-Index: linux-3.10/arch/mips/ath79/Kconfig
-===================================================================
---- linux-3.10.orig/arch/mips/ath79/Kconfig    2013-07-11 22:29:04.592988418 +0200
-+++ linux-3.10/arch/mips/ath79/Kconfig 2013-07-11 22:41:53.245006256 +0200
-@@ -2,6 +2,61 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -2,6 +2,61 @@ if ATH79
  
  menu "Atheros AR71XX/AR724X/AR913X machine selection"
  
@@ -194,7 +190,7 @@ Index: linux-3.10/arch/mips/ath79/Kconfig
  config ATH79_MACH_AP121
        bool "Atheros AP121 reference board"
        select SOC_AR933X
-@@ -11,62 +66,654 @@
+@@ -11,62 +66,656 @@ config ATH79_MACH_AP121
        select ATH79_DEV_M25P80
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
@@ -498,7 +494,7 @@ Index: linux-3.10/arch/mips/ath79/Kconfig
 +
 +config ATH79_MACH_RB95X
 +       bool "MikroTik RouterBOARD 95X support"
-+       select SOC_AR934x
++       select SOC_AR934X
 +       select ATH79_DEV_ETH
 +       select ATH79_DEV_NFC
 +       select ATH79_DEV_WMAC
@@ -508,11 +504,14 @@ Index: linux-3.10/arch/mips/ath79/Kconfig
 +
 +config ATH79_MACH_RB2011
 +      bool "MikroTik RouterBOARD 2011 support"
-+      select SOC_AR934x
++      select SOC_AR934X
 +      select ATH79_DEV_ETH
++      select ATH79_DEV_M25P80
 +      select ATH79_DEV_NFC
++      select ATH79_DEV_USB
 +      select ATH79_DEV_WMAC
 +      select ATH79_ROUTERBOOT
++      select RLE_DECOMPRESS
 +
 +config ATH79_MACH_WNDAP360
 +      bool "NETGEAR WNDAP360 board support"
@@ -522,7 +521,6 @@ Index: linux-3.10/arch/mips/ath79/Kconfig
 +      select ATH79_DEV_GPIO_BUTTONS
 +      select ATH79_DEV_LEDS_GPIO
 +      select ATH79_DEV_M25P80
-+      select ATH79_DEV_USB
 +
 +config ATH79_MACH_WNDR3700
 +      bool "NETGEAR WNDR3700 board support"
@@ -875,7 +873,7 @@ Index: linux-3.10/arch/mips/ath79/Kconfig
  
  config ATH79_MACH_UBNT_XM
        bool "Ubiquiti Networks XM/UniFi boards"
-@@ -83,6 +730,34 @@
+@@ -83,6 +732,34 @@ config ATH79_MACH_UBNT_XM
          Say 'Y' here if you want your kernel to support the
          Ubiquiti Networks XM (rev 1.0) board.
  
@@ -910,7 +908,7 @@ Index: linux-3.10/arch/mips/ath79/Kconfig
  endmenu
  
  config SOC_AR71XX
-@@ -132,7 +807,10 @@
+@@ -132,7 +809,10 @@ config ATH79_DEV_DSA
  config ATH79_DEV_ETH
        def_bool n
  
@@ -922,7 +920,7 @@ Index: linux-3.10/arch/mips/ath79/Kconfig
        def_bool n
  
  config ATH79_DEV_GPIO_BUTTONS
-@@ -164,4 +842,7 @@
+@@ -164,4 +844,7 @@ config ATH79_PCI_ATH9K_FIXUP
  config ATH79_ROUTERBOOT
        def_bool n
  
@@ -930,11 +928,9 @@ Index: linux-3.10/arch/mips/ath79/Kconfig
 +      def_bool n
 +
  endif
-Index: linux-3.10/arch/mips/ath79/Makefile
-===================================================================
---- linux-3.10.orig/arch/mips/ath79/Makefile   2013-07-11 22:29:04.400988414 +0200
-+++ linux-3.10/arch/mips/ath79/Makefile        2013-07-11 22:42:39.673007333 +0200
-@@ -38,9 +38,79 @@
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -38,9 +38,79 @@ obj-$(CONFIG_ATH79_ROUTERBOOT)              += route
  #
  # Machines
  #
@@ -1014,11 +1010,9 @@ Index: linux-3.10/arch/mips/ath79/Makefile
 +obj-$(CONFIG_ATH79_MACH_WZR_HP_G450H) += mach-wzr-hp-g450h.o
 +obj-$(CONFIG_ATH79_MACH_ZCN_1523H)    += mach-zcn-1523h.o
 +obj-$(CONFIG_ATH79_MACH_CARAMBOLA2)   += mach-carambola2.o
-Index: linux-3.10/arch/mips/ath79/prom.c
-===================================================================
---- linux-3.10.orig/arch/mips/ath79/prom.c     2013-07-11 22:29:04.128988408 +0200
-+++ linux-3.10/arch/mips/ath79/prom.c  2013-07-11 22:29:04.620988419 +0200
-@@ -180,6 +180,11 @@
+--- a/arch/mips/ath79/prom.c
++++ b/arch/mips/ath79/prom.c
+@@ -180,6 +180,11 @@ void __init prom_init(void)
                        ath79_prom_append_cmdline("board", env);
                }
        }