ar71xx: switch to linux 3.14
[openwrt.git] / target / linux / ar71xx / patches-3.10 / 310-lib-add-rle-decompression.patch
index 5c43ae2..46cdacd 100644 (file)
@@ -12,7 +12,7 @@
  # ZLIB_INFLATE; DECOMPRESS_GZIP is just a wrapper.)
 --- a/lib/Makefile
 +++ b/lib/Makefile
-@@ -89,6 +89,7 @@ obj-$(CONFIG_XZ_DEC) += xz/
+@@ -90,6 +90,7 @@ obj-$(CONFIG_XZ_DEC) += xz/
  obj-$(CONFIG_RAID6_PQ) += raid6/
  obj-$(CONFIG_LZMA_COMPRESS) += lzma/
  obj-$(CONFIG_LZMA_DECOMPRESS) += lzma/
  lib-$(CONFIG_DECOMPRESS_BZIP2) += decompress_bunzip2.o
 --- /dev/null
 +++ b/include/linux/rle.h
-@@ -0,0 +1,8 @@
+@@ -0,0 +1,18 @@
 +#ifndef _RLE_H_
 +#define _RLE_H_
 +
++#ifdef CONFIG_RLE_DECOMPRESS
 +int rle_decode(const unsigned char *src, size_t srclen,
 +             unsigned char *dst, size_t dstlen,
 +             size_t *src_done, size_t *dst_done);
++#else
++static inline int
++rle_decode(const unsigned char *src, size_t srclen,
++         unsigned char *dst, size_t dstlen,
++         size_t *src_done, size_t *dst_done)
++{
++      return -ENOTSUPP;
++}
++#endif /* CONFIG_RLE_DECOMPRESS */
 +
 +#endif /* _RLE_H_ */
 --- /dev/null