ar71xx: remove support for 2.6.36
[openwrt.git] / target / linux / ar71xx / patches-2.6.36 / 206-nxp-74hc153-gpio-chip-driver.patch
diff --git a/target/linux/ar71xx/patches-2.6.36/206-nxp-74hc153-gpio-chip-driver.patch b/target/linux/ar71xx/patches-2.6.36/206-nxp-74hc153-gpio-chip-driver.patch
deleted file mode 100644 (file)
index c2d0976..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/drivers/gpio/Kconfig
-+++ b/drivers/gpio/Kconfig
-@@ -361,4 +361,12 @@ config GPIO_JANZ_TTL
-         This driver provides support for driving the pins in output
-         mode only. Input mode is not supported.
-+comment "Other GPIO expanders"
-+
-+config GPIO_NXP_74HC153
-+      tristate "NXP 74HC153 Dual 4-input multiplexer"
-+      help
-+        Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
-+        provides a GPIO interface supporting inputs.
-+
- endif
---- a/drivers/gpio/Makefile
-+++ b/drivers/gpio/Makefile
-@@ -17,6 +17,7 @@ obj-$(CONFIG_GPIO_MAX7301)   += max7301.o
- obj-$(CONFIG_GPIO_MAX732X)    += max732x.o
- obj-$(CONFIG_GPIO_MC33880)    += mc33880.o
- obj-$(CONFIG_GPIO_MCP23S08)   += mcp23s08.o
-+obj-$(CONFIG_GPIO_NXP_74HC153)        += nxp_74hc153.o
- obj-$(CONFIG_GPIO_PCA953X)    += pca953x.o
- obj-$(CONFIG_GPIO_PCF857X)    += pcf857x.o
- obj-$(CONFIG_GPIO_PL061)      += pl061.o