ar71xx: enable USB packages for WNR2200 (fixes #21984)
[openwrt.git] / target / linux / ar71xx / generic / profiles / zyxel.mk
index 8004d15..991a13a 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/NBG_460N_550N_550NH
        NAME:=Zyxel NBG 460N/550N/550NH
-       PACKAGES:=kmod-ath9k kmod-rtc-pcf8563 swconfig uboot-ar71xx-nbg460n_550n_550nh
+       PACKAGES:=kmod-rtc-pcf8563
 endef
 
 define Profile/NBG_460N_550N_550NH/Description
@@ -15,3 +15,15 @@ define Profile/NBG_460N_550N_550NH/Description
 endef
 
 $(eval $(call Profile,NBG_460N_550N_550NH))
+
+
+define Profile/NBG6616
+       NAME:=ZyXEL NBG6616
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev kmod-usb-storage kmod-rtc-pcf8563 kmod-ath10k
+endef
+
+define Profile/NBG6616/Description
+       Package set optimized for the ZyXEL NBG6616
+endef
+
+$(eval $(call Profile,NBG6616))