ar71xx: Add Support for the Bitmain Antminer S1
[15.05/openwrt.git] / target / linux / ar71xx / generic / profiles / antminer.mk
diff --git a/target/linux/ar71xx/generic/profiles/antminer.mk b/target/linux/ar71xx/generic/profiles/antminer.mk
new file mode 100644 (file)
index 0000000..366982c
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ANTMINER_S1
+       NAME:=Antminer S1
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-crypto-manager kmod-i2c-gpio-custom kmod-usb-hid
+endef
+
+
+define Profile/ANTMINER_S1/Description
+       Package set optimized for the Bitmain Antminer S1.
+endef
+$(eval $(call Profile,ANTMINER_S1))