[ar71xx] make sure the console works when using procd as our pid 1
[openwrt.git] / target / linux / ar71xx / base-files.mk
index d6682bd..5ee4dbd 100644 (file)
@@ -1,5 +1,7 @@
 define Package/base-files/install-target
        rm -f $(1)/etc/config/network
+       $(if $(CONFIG_PROCD_INIT),rm -f  $(1)/etc/uci-defaults/00_inittab-console-fixup)
+       $(if $(CONFIG_PROCD_INIT),echo "::askconsole:/bin/ash --login" >> $(1)/etc/inittab)
 endef