ar71xx: ethernet: do not update the unused dev->last_rx field
[openwrt.git] / target / linux / ar71xx / Makefile
index db3f770..07e24ee 100644 (file)
@@ -10,15 +10,15 @@ ARCH:=mips
 BOARD:=ar71xx
 BOARDNAME:=Atheros AR7xxx/AR9xxx
 FEATURES:=squashfs targz mips16
-CFLAGS:=-Os -pipe -mips32r2 -mtune=34kc -fno-caller-saves -mno-branch-likely
+CFLAGS:=-Os -pipe -mips32r2 -mtune=34kc -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.8.13
+LINUX_VERSION:=3.10.4
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-gpio-button-hotplug kmod-wdt-ath79 swconfig \
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
        kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev \
        kmod-ath9k wpad-mini uboot-envtools