Fix warnings
[openwrt.git] / target / linux / ar7-2.4 / Makefile
index e15eb09..87c2470 100644 (file)
@@ -6,9 +6,21 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.4.32
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=38f4d0830e95a20f4bfed17622d5557c
+ARCH:=mipsel
+BOARD:=ar7
+BOARDNAME:=TI AR7
+FEATURES:=squashfs jffs2
+
+define Target/Description
+       Build firmware images for TI AR7 based routers (w.g. Linksys WAG54G v2)
+endef
+
+KERNEL:=2.4
 
 include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += kmod-avalanche-cpmac
+
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))