adm5120: drop 3.8 and 3.14 support
[15.05/openwrt.git] / target / linux / adm5120 / patches-3.8 / 310-adm5120_wdt.patch
diff --git a/target/linux/adm5120/patches-3.8/310-adm5120_wdt.patch b/target/linux/adm5120/patches-3.8/310-adm5120_wdt.patch
deleted file mode 100644 (file)
index 56f345e..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/drivers/watchdog/Kconfig
-+++ b/drivers/watchdog/Kconfig
-@@ -985,6 +985,18 @@ config RC32434_WDT
-         To compile this driver as a module, choose M here: the
-         module will be called rc32434_wdt.
-+config ADM5120_WDT
-+      tristate "Infineon ADM5120 SoC hardware watchdog"
-+      depends on WATCHDOG && ADM5120
-+      help
-+        This is a driver for hardware watchdog integrated in Infineon
-+        ADM5120 SoC. This watchdog simply watches your kernel to make sure
-+        it doesn't freeze, and if it does, it reboots your computer after a
-+        certain amount of time.
-+
-+        To compile this driver as a module, choose M here: the module will be
-+        called adm5120_wdt.
-+
- config INDYDOG
-       tristate "Indy/I2 Hardware Watchdog"
-       depends on SGI_HAS_INDYDOG
---- a/drivers/watchdog/Makefile
-+++ b/drivers/watchdog/Makefile
-@@ -122,6 +122,7 @@ obj-$(CONFIG_ATH79_WDT) += ath79_wdt.o
- obj-$(CONFIG_BCM47XX_WDT) += bcm47xx_wdt.o
- obj-$(CONFIG_BCM63XX_WDT) += bcm63xx_wdt.o
- obj-$(CONFIG_RC32434_WDT) += rc32434_wdt.o
-+obj-$(CONFIG_ADM5120_WDT) += adm5120_wdt.o
- obj-$(CONFIG_INDYDOG) += indydog.o
- obj-$(CONFIG_JZ4740_WDT) += jz4740_wdt.o
- obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o